12.10 html return of secure and non-secure content

Bug #1069291 reported by Doug Smythies
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Undecided
Jeremy Bicha

Bug Description

when 12.04 was released, some web browsers complained of secure and non-secure content on every html page of the server guide.
The problematic line was:

<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script><script type="text/javascript" src="js/main.js"></script>

A few solutions were discussed, but the final solution that was implemented was to delete the line. (Solution was proposed and implemented by Jeremy Bicha.)

This line has re-appeared in the 12.10 html serverguide, and thus so has the browsing issue.

Hmmm...
Issue also exists in HTML 11.10 server guide.

Revision history for this message
Doug Smythies (dsmythies) wrote :

O.K. I am reasonably confused.
I thought I might try to help by making a merge proposal for this issue. After all, I knew (or so I thought) exactly what to do from last time with 12.04 (see doc group e-mails on and about 2012.04.26).
However, that line is already not there in /libs/ubuntu.xsl, nor does a reference compile of the HTML serverguide have the issue.
I checked again at https://help.ubuntu.com/12.10/serverguide/index.html and it has the issue and the source html has the problematic line.

Revision history for this message
Doug Smythies (dsmythies) wrote :

I see that Jeremy Bicha had already fixed this issue about an hour before I tired to fix it. (He fixed 11.10 also) I suppose it just has not made its way to the main web site yet. Mystery solved.
See revision 97 (12.10) and revision 39 (11.10)

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Ah, sorry Doug for not setting this bug to "In Progress". I didn't realize you were going to try to fix it too. I think I made the necessary changes to https://code.launchpad.net/~ubuntu-core-doc/ubuntu-docs/help.ubuntu.com but the live website only pulls from that repo once per day so we have to wait a few more hours to check if it worked.

I also made some changes to the serverguide repos themselves since that is what we use to build the docs for that other branch and unless it's fixed there we can easily reintroduce the bug (as happened this time for 12.10).

Changed in serverguide:
status: New → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha)
Changed in serverguide:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers