typo in multipath device handler setup

Bug #1057071 reported by Peter Petrakis
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Undecided
Unassigned

Bug Description

In the "note" section on:

https://help.ubuntu.com/12.04/serverguide/multipath-dm-multipath-config-file.html

"""
Whenever a hardware_handler is specified, it is your responsibility to ensure that the appropriate kernel module is loaded to support the specified interface. These modules can be found in /lib/modules/`uname -r`/kernel/drivers/scsi/device_handler/ . The requisite module should be integrated into the initrd to ensure the necessary discovery and failover-failback capacity is available during boot time. Example,

# cat scsi_dh_alua >> /etc/initramfs-tools/modules ## append module to file
# update-initramfs -u -k all
"""

That "cat" command is wrong, it should have been "echo". Thankfully no harm is done in it's current
form, no good is done either.

Changed in serverguide:
status: New → Confirmed
Changed in serverguide:
status: Confirmed → In Progress
Revision history for this message
Doug Smythies (dsmythies) wrote :

Fix is in master source for precise, quantal, and raring. Nothing had to be done for raring, but it is there.

Changed in serverguide:
status: In Progress → Fix Committed
Revision history for this message
Doug Smythies (dsmythies) wrote :

Correction: Raring had to be manually done, and now is. It does not show in the related branches above due to a typo in my bzr commit.

Changed in serverguide:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers