mutex class conflicts with mutex in gtkmm

Bug #1647614 reported by Bugs Bunny on 2016-12-06
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Seq24
Undecided
Unassigned
seq24 (Debian)
Fix Released
Unknown
seq24 (Ubuntu)
Undecided
Unassigned

Bug Description

Seq24 0.9.3 cannot be built with gtkmm 2.24.4 and GCC 4.9.4, because the custom "mutex" class conflicts with the "mutex" class provided by gtkmm. To build Seq24 for GNU Guix we renamed the Seq24 "mutex" class to "seq24mutex" to avoid the ambiguity.

Please consider either using "::mutex" or renaming the class to prevent ambiguity errors.

Changed in seq24 (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in seq24 (Ubuntu):
status: New → Confirmed
James Cowgill (jcowgill) wrote :

Here's the patch which I'll likely apply to the Debian/Ubuntu package.

The attachment "01-mutex.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in seq24 (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seq24 - 0.9.3-2

---------------
seq24 (0.9.3-2) unstable; urgency=medium

  * Team upload.
  * Use debhelper compat 10 and dh-autoreconf.
  * Install AUTHORS, SEQ24 and seq24usr.example files. (Closes: #732107)
  * Use PNG application icon.

  * debian/changelog:
    - Remove trailing whitespace from debian/changelog.
  * debian/copyright:
    - Add missing copyright info
  * debian/control:
    - Bump standards version to 4.1.2.
  * debian/patches:
    - Add patch to fix FTBFS - error: reference to 'mutex' is ambiguous.
      (Closes: #822394, LP: #1647614)
  * debian/rules:
    - Use DEB_LDFLAGS_MAINT_APPEND to adjust LDFLAGS.

 -- James Cowgill <email address hidden> Fri, 01 Dec 2017 17:16:27 +0000

Changed in seq24 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.