Screenlet-name is shown in global menu

Bug #753652 reported by Alexander Kallenbach on 2011-04-07
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Screenlets
Wishlist
Unassigned

Bug Description

If there are no other programms opened, the global menu in Natty shows the name of the screenlet.

Märt Põder (boamaod) on 2011-04-20
Changed in screenlets:
status: New → Confirmed
importance: Undecided → Wishlist
Märt Põder (boamaod) wrote :

Is there a way to exclude application from global menu like there is possibility to hide applications from taskbar or task switcher using extended window manager hints (EWMH)?

Kai Hendrik Behrends (kbehren) wrote :

Here is a screenshot for people who don't exactly know what is meant. (look at the upper left)

Märt Põder (boamaod) wrote :

If you move focus on screenlet, the filename of is shown in application menu. If you click on empty desktop, the filename disappears.

Edvinas (ikonitas) wrote :

I am having this issue as well, if I deleted file from my DESKTOP, I focus on screenlet thank, its really annoying as you have double click on desktop, a filename to dissapear

Kai Hendrik Behrends (kbehren) wrote :

I think this blog post might include a way to fix this:
http://www.webupd8.org/2011/03/disable-appmenu-global-menu-in-ubuntu.html

It includes a way how to disable the appmenu for a single application that should be usable.

Kai Hendrik Behrends (kbehren) wrote :

OK sorry tried to apply this. Turns out it just affects the menu displayed not the name so no fix here.

Märt Põder (boamaod) wrote :

Actually, displaying a name of screenlet in the application menu is intended behaviour in Ubuntu Natty. Maybe what should be displayed shouldn't be "WhateverScreenlet.py", but just "Whatever". This can be done by providing a desktop file in /usr/share/applications or ~/.local/share/applications. In future versions of screenlets, there will be screenlet.desktop file provided with screenlets, but I believe the default value will not be empty string (to make the application menu title disappear). But this is open to discussion.

If you want to modify the behaviour yourself, you have some options:

1. Create a laucher (desktop file) and specify the name for your screenlet there (it can be left empty, maybe you have to enter one space or something). Copy it to one of the directories specified above. Log out to update desktop files or find out how to refresh desktop file database. You can also copy desktop file from ~/.config/autostart if you have screenlet in auto start list.

2. Dont want to create desktop files? Use a custom command to start a screenlet. For example "cat /usr/share/screenlets/screenlets-pack-basic/Lipik/LipikScreenlet.py | python" gives interesting results, instead of the name of screenlet, the title will contain just a dot ("."). If you like "-" instead of "." you may try "cat /usr/share/screenlets/screenlets-pack-basic/Lipik/LipikScreenlet.py | python".

3. Change the name of the python script to modify the title (it may make the screenlet not functional, but this depends on the individual screenlet itself).

Märt Põder (boamaod) on 2011-05-31
Changed in screenlets:
status: Confirmed → Fix Committed
Märt Põder (boamaod) wrote :

I commited the new versions of screenlets into Dev PPA (https://launchpad.net/~screenlets-dev/+archive/ppa). Now the deskop files are installed and instead of "WhateverScreenlet.py" the title is "Whatever". Logging out and back in may be required to update the titles (it's probably because of the relative youth of Unity).

If you still want to disable all the titles, you have to make an effort yourself. Maybe something like...

Copy screenlets desktop files to your own desktop file directory:
mkdir -p ~/.local/share/applications/
cp -rv /usr/share/applications/screenlets/ /usr/share/applications/screenlets-pack-all/ /usr/share/applications/screenlets-pack-basic/ ~/.local/share/applications/

Change all the name fields for them:
find ~/.local/share/applications/screenlets/ ~/.local/share/applications/screenlets-pack-all/ ~/.local/share/applications/screenlets-pack-basic/ -name "*.desktop" | xargs sed -ri -e "s/(Name.*=)(.*)/\1 /g"

Delete the files from your home directory, if you don't like the changes made:
rm -rv ~/.local/share/applications/screenlets/ ~/.local/share/applications/screenlets-pack-all/ ~/.local/share/applications/screenlets-pack-basic/

Märt Põder (boamaod) on 2011-06-27
Changed in screenlets:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments