Serious visual flaws in Natty

Bug #717989 reported by Märt Põder on 2011-02-13
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Screenlets
High
Unassigned
screenlets (Ubuntu)
Undecided
Julien Lavergne

Bug Description

See the attached picture.

* Some screenlets flicker when redrawing (or redrawing too much)
* Some screenlets do not display graphics all right (themes, pictures, gtk elements)
* There are extra decorations in lower right corner (see the triangle), but doesn't even seem to function in any way

These things might be just temporary of course, since it's an alpha version of Natty.

Related branches

Märt Põder (boamaod) wrote :
Papp Bence (sclegnrbs) on 2011-02-13
Changed in screenlets:
status: New → Confirmed
importance: Undecided → High
Papp Bence (sclegnrbs) on 2011-02-13
Changed in screenlets:
milestone: none → 0.1.4
Mostafa Razavi (elektito) wrote :

The bug still exists in Beta and makes some screenlets (including one I've been writing and worked perfectly well in Maverick) quite unusable. I see a milestone has been assigned. Does this mean that by 0.1.4 the bug is supposed to be fixed? If so, are there any estimations as to when 0.1.4 is going to be released?

Märt Põder (boamaod) wrote :

There is nobody really actively developing Screenlets and I believe these bugs will be fixed, but not too fast. It can even take months. Only way to be sure is to help to diagnose the bugs, provide some ideas or even patches to fix them or join the project and fix the bugs yourself. Which bug is the one that bothers you?

Mostafa Razavi (elektito) wrote :

The flickering is the one I have encountered. I have thought about looking at the problem myself. I know python, and I have some familiarity with screenlets code base too, but frankly I don't even know where to look for the source of this bug. I mean, this is not a straightforward functional bug. It might even be that screenlets is not at fault at all. Couldn't this be a problem with compiz?

Märt Põder (boamaod) wrote :

I think it may be connected with new version of GTK, but I have really no proof. I have also noticed that not every screenlet flickers the same way. Some flicker way more than others. Also, for my experience, Alpha version flickered much more than Beta version flickers. I think digging the redraw routines can give some hint what could be causing the flicker.

Maybe also some other projects have noticed flickering in Natty and have solutions.

If I have time, I'll try to look into this, but I'm not sure when.

Mostafa Razavi (elektito) wrote :

In my own screenlet, there is a noticeable flicker every single time the screenlet is redrawn. The draw method mostly composes several svg images to create its interface.

Mostafa Razavi (elektito) wrote :

More testing seems to show that svg images have nothing to do with the problem; the problem persists even when I replace the svg drawing calls with other random drawing calls.

Claudiu Vlad (claudiu-vlad) wrote :

I can confirm this bug.

Are there alternatives to screenlets for Natty+ ? If not, I suppose we need this to be fixed.

Märt Põder (boamaod) wrote :

I tested it with the latest updates for Natty and it appears that the flickering is much reduced. Now, for example Clock screenlet does not flicker at all, although it updates the graphics once in a second. At the same time Meter and Sensors screenlets still do some flickering.

Clearweather still shows serious flickering.

On Mon, Apr 18, 2011 at 5:47 PM, tabbernuk <email address hidden> wrote:

> I tested it with the latest updates for Natty and it appears that the
> flickering is much reduced. Now, for example Clock screenlet does not
> flicker at all, although it updates the graphics once in a second. At
> the same time Meter and Sensors screenlets still do some flickering.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/717989
>
> Title:
> Serious visual flaws in Natty
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/screenlets/+bug/717989/+subscribe
>

Märt Põder (boamaod) wrote :

Tried to fix it in revision #646: Remove flicker and resize grips. Please try, if it works for you. The updated package version (something like 0.1.4~bzr646) should be in ppa:screenlets-dev/ppa in 24h.

Märt Põder (boamaod) on 2011-04-19
Changed in screenlets:
status: Confirmed → Fix Committed
Mostafa Razavi (elektito) wrote :

Thank you. It works perfectly well for me.

Julien Lavergne (gilir) on 2011-04-20
Changed in screenlets (Ubuntu):
status: New → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package screenlets - 0.1.3-0ubuntu2

---------------
screenlets (0.1.3-0ubuntu2) natty; urgency=low

  * debian/patches/90-disable-resize-grip.patch:
   - From upstream (rev 646), disable resize grip (LP: #717989)
 -- Julien Lavergne <email address hidden> Sat, 23 Apr 2011 19:40:12 +0200

Changed in screenlets (Ubuntu):
status: In Progress → Fix Released
Märt Põder (boamaod) on 2011-06-27
Changed in screenlets:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments