Screenkey freeze when clicking the icon in the panel and doesn't react anymore

Bug #591487 reported by themeles on 2010-06-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Screenkey
Medium
Pablo SEMINARIO

Bug Description

Screenkey freeze when left clicking the icon in the panel and doesn't react anymore. The latest keys are still shown in the overlay but no new ones. Clicking the panel icon doesn't change anything also no right click. Only killing the program removes the overlay.

Pablo SEMINARIO (pabluk) wrote :

Thanks meles,
In the next release I'll add a debug option to see wich key combination causes this bug.

Changed in screenkey:
status: New → Confirmed
importance: Undecided → Medium
themeles (themeles) wrote :

I tried to find the keys or key combination which cause the problems because I found out that it's no just the mouse. I tried many variations but I couldn't find any scheme. I recorded the pressed buttons and post the file below. First I just recorded the key numbers after it I recorded it more detailed. "NEW SESSION" in the file, means that the program crashed and I restarted it. I hope the file is useful in any case.
My latest guess was that changing the focus of the windows (even with the mouse) leads to the crash but I couldn't confirm.

Pablo SEMINARIO (pabluk) wrote :

Thanks for your feedback meles, I'm working to add a debug option to make it easier.

Pablo SEMINARIO (pabluk) on 2010-06-11
Changed in screenkey:
assignee: nobody → Pablo Seminario (pabluk)
status: Confirmed → In Progress
Pablo SEMINARIO (pabluk) on 2010-06-12
Changed in screenkey:
status: In Progress → Fix Committed
Pablo SEMINARIO (pabluk) wrote :

@meles I have added an option to debug, you should update and run the application on a terminal with this command
   $ screenkey --debug --no-detach
to see wich key combination causes the problem

Changed in screenkey:
status: Fix Committed → Fix Released
milestone: none → 0.2.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments