Don't see any icon

Bug #1021647 reported by Damien Cassou on 2012-07-06
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Screenkey
High
Pablo SEMINARIO

Bug Description

When I launch screenkey on ubuntu 12.04, it seems to work ok but there is no icon to access screenkey's menu and preferences.

Pablo SEMINARIO (pabluk) wrote :

Hi Damien,

I will check this problem on Ubuntu 12.04. Which installation method do you use? apt-get install screenkey?

Thanks!

Damien Cassou (cassou) wrote :

Thank you Pablo. I used the last version from the trunk (bzr branch lp:screenkey). After trying many times, I have to confess it sometimes work :-)

Pablo SEMINARIO (pabluk) wrote :

Bug confirmed. I will try to fix it.

Changed in screenkey:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Pablo Seminario (pabluk)
Bob Maerten (bob-maerten-9) wrote :

Ubuntu, since 11.04 doesn't allow many apps to show icons in the notification zone (systray). In order to authorize screenkey in systray, you can use dconf-editor (GUI) or gsettings (console) to add/update the "com.canonical.Unity.Panel systray-whitelist" with "screenkey" string. It's probably the responsability of the package maintener to do that on install.

Anyway, I still fall back on other open bugs (#658018 and #756346) : the icon is not responsive or hangs completly the app, so that i can't configure it.

Using default setting, then. Could you think of a config file ($HOME/.screenkeyrc ?) in order to set up the app ?

Damien Cassou (cassou) wrote :

A config file would be great. 2 things:

- what about ~/.config/screekeyrc instead so that freedesktop specifications are followed? http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html

- what about finer grained configuration which would replace BOTTOM/MIDDLE/TOP by absolute position in pixels (and same thing for the font size)?

Pablo SEMINARIO (pabluk) wrote :

Damian,

I see the problem, and I think that we need rewrite some parts of the code base to use the new ApplicationIndicators https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators

Regarding configuration, yes, I need move the file to the standard place. And I have added your suggestion to Screenkey's Blueprint https://blueprints.launchpad.net/screenkey/+spec/advanced-options

Thanks!

JPi (ajuanpi) wrote :

Hi Pablo,

Any activity on this?
Installing from software center in 13.10, the icon still doesn't appear. I will update the systray-whitelist as Bob suggested.

Have you abandoned this project? I hope not!

Thank you very much

JPi (ajuanpi) wrote :

Sadly Ubuntu 13.10 doesn't allow whitelisting anymore.
Is it possible to borrow some code from recordmydesktop gui to solve this problem? Thier try icon works fine
https://sourceforge.net/p/recordmydesktop/svn/HEAD/tree/trunk/gtk-recordmydesktop/src/rmdTrayIcon.py

Pablo SEMINARIO (pabluk) wrote :

Hi!

Yes, with the latest versions of X11/Xorg/Unity there are many things that have changed and the project needs a refactoring, but unfortunately I no longer have much time to work on Screenkey.

I'll add a message on the project page to find a new maintainer.

Thanks for your support,

Cheers,

Leonardo Donelli (learts92) wrote :

As a quick workaround just add an `import appindicator` at the start of the Screenkey.py file, for example after the line: `import gtk`, and it will work.

I'm looking into it as I may be interested in tooking over the project :)

Leonardo Donelli (learts92) wrote :

So, I just noticed there already is the appindicator implementation (lines [137,154]) so it's really strange that it works if I add it at the beginning as I suggested in my previous comment.

I tried to debug the problem and I noticed that the indicator works if I start screenkey with the --no-detach option.
I then commented the call to self.drop_tty and it works even without the --no-detach option
I assume therefore the problem must be related to the fork call -- unfortunately i'm no expert in multithreading, I'll have to read a lot about it.

Pablo SEMINARIO (pabluk) wrote :

Tell me if you need write permissions to merge changes, I can add you as maintainer.

Thanks Leonardo!

Hi,
I also downloaded and installed screenkey in ubuntu 14.04 and it works fine but no icon to access menu also as mentioned above. Is this bug fixed? I also tried to edit Screenkey.py as suggested by Leonardo but my editor says unable to save /usr/share/pyshared/Screenkey/screenkey.py
Hope anyone can help me.
Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers