Alt + Number should switch to tab

Bug #965534 reported by Christian Dywan on 2012-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
Marcus Lundgren
Scratch
Invalid
Undecided
Unassigned

Bug Description

I'm used to Empathy, Midori, gedit and Terminal switching tabs by Alt + Number. I'd love Scratch to support it as well.

Related branches

Christian Dywan (kalikiana) wrote :

In fact I wonder if this could/ should be solved in Granite.DynamicNotebook out of the box.

Mario Guerriero (mefrio-g) wrote :

I think it is a feature that apps should have, not a granite's bug

Changed in scratch:
status: New → Confirmed
importance: Undecided → Wishlist
Changed in granite:
status: New → Invalid
Christian Dywan (kalikiana) wrote :

To be honest I didn't yet investigate how feasible that option was. My point was merely, if all apps using Granite.DynamicNotebook can have it for free, that'd save everyone some time and get it to users for free. It's very possible it would require logic in apps anyway because focus may be in the wrong widget and maybe should be part of the design guide instead.

Mario Guerriero (mefrio-g) wrote :

This feature should be accepted by the design team so and be putted in the HIGs

Daniel Fore (danrabbit) wrote :

We do have a doc going for keyboard shortcuts https://docs.google.com/document/d/1jUtWkfqlwDydaO-B67F9PsOhE66AZ2y5N_uDRW9pOuQ/edit

The doc lists "Ctrl + %n" for tab switching. If the traditional shortcut is really "Alt + %n" then we should change that in the doc.

But I agree with Christian, if it's possible to bake this shortcut directly into Granite that would be better so that all the apps can get it for free.

xapantu (xapantu) wrote :

Yes, it must definitively be in granite. Maybe it will require some API calls in order to connect the signals, I'm not sure yet, but at least there must be some facilities in granite.

Changed in granite:
status: Invalid → Confirmed
importance: Undecided → Low
Changed in scratch:
status: Confirmed → Invalid
importance: Wishlist → Undecided
Cody Garver (codygarver) on 2012-04-14
Changed in granite:
milestone: none → 0.2
Christian Dywan (kalikiana) wrote :

Latest DynamicNotebook has Ctrl+n support. This is wrong, it needs to change to Alt+n which is really the prevalent hotkey.

Changed in granite:
importance: Low → High

Retargeting to beta1 because this is almost done; untarget if any complications occur

Changed in granite:
milestone: 0.2 → luna-beta1
Changed in granite:
assignee: nobody → Marcus Lundgren (marcus-lundgren)
status: Confirmed → In Progress
Cody Garver (codygarver) on 2012-07-22
Changed in granite:
status: In Progress → Fix Committed
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers