Deleting file open in Scratch recreates it

Bug #962465 reported by Sergey "Shnatsel" Davidoff on 2012-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Scratch
Fix Released
Medium
Mario Guerriero

Bug Description

Deleting a file which is open in Scratch makes Scratch ask if the file should be updated, and if updating is accepted, the file is written back to disk. It's just me or something is wrong here?
(yeah, I know, I do lots of stupid things with open files)

description: updated
Changed in scratch:
assignee: nobody → elementary UX Team (elementary-design)
Changed in scratch:
status: New → Confirmed
importance: Undecided → Medium

Maybe if scratch opens a file and its deleted by an external source, saving will open the save as dialog?

Mario Guerriero (mefrio-g) wrote :

Showing the save as dialog is not too obvious

Changed in scratch:
milestone: none → luna-beta1
Daniel Fore (danrabbit) wrote :

I think maybe what Harvey was trying to say is that when you delete a file, the "Save As" icon is shown in the toolbar (as if it's a new file). And we just treat it as a New file.

Which I think isn't a terrible idea.

Mario Guerriero (mefrio-g) wrote :

I suggest to show a dialog saying something like "This file was deleted, do you want to recreate it?"

Daniel Fore (danrabbit) wrote :

Mario, what if you're not focusing the tab that has the deleted item? Maybe it should be an infobar?

Mario Guerriero (mefrio-g) wrote :

There could be an infobar after focusing the tab...

Daniel Fore (danrabbit) wrote :

Yea that sounds fine to me :)

Mario Guerriero (mefrio-g) wrote :

Ok so let's fixing this bug

Changed in scratch:
assignee: elementary UX Team (elementary-design) → Mario Guerriero (mefrio-g)
Mario Guerriero (mefrio-g) wrote :

Oh I'm just realized that there is a warning dialog in the case a file was deleted but it wasn't shown for a little bug. So this bug is fixed for the moment. I don't want to do it for now but for Scratch 1.2 I will need to create a better InfoBar system because, if I use the current one to fix this bug, there could be problems when showing a warning message in the InfoBar. For now it is ok so

Changed in scratch:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers