No unsaved changes dialog on logout

Bug #962106 reported by Sergey "Shnatsel" Davidoff on 2012-03-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Scratch
Fix Released
Medium
Mario Guerriero

Bug Description

Scratch doesn't prevent user logout when there's a file with unsaved changes and either autosave turned off or no save location set yet.

Steps to reproduce: Open Scratch, create new document, type something. Log out.

Changed in scratch:
milestone: none → luna-beta1
tags: added: data-loss
Changed in scratch:
status: New → Confirmed
importance: Undecided → Medium
Changed in scratch:
assignee: nobody → Andrea Basso (voluntatefaber)
Andrea Basso (voluntatefaber) wrote :

At the moment I don't think I have time/knowledge enough to be able to fix this one.

To fix this bug, Scratch need to use D-Bus and register itself using this API http://people.gnome.org/~mccann/gnome-session/docs/gnome-session.html

Mario Guerriero (mefrio-g) wrote :

So since Fabian is working on this bug and Andrea said that he don't have time/knowledge enought to fix it, I assign it to Fabian

Changed in scratch:
assignee: Andrea Basso (voluntatefaber) → Fabian Thoma (agent00tai)
Changed in scratch:
assignee: Fabian Thoma (agent00tai) → Mario Guerriero (mefrio-g)
Mario Guerriero (mefrio-g) wrote :

I tested it on Ubuntu and it doesn't work but, following GNOME documentation, it shouldn't work on every type of sessions (even if I find it strange). Can anyone test?

Changed in scratch:
status: Confirmed → In Progress
Changed in scratch:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers