Unable to access HeaderBar in fullscreen [$15]

Bug #1256739 reported by Daniel Fore on 2013-12-02
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Maya
Fix Released
Medium
Unassigned
Noise
Fix Released
Undecided
Unassigned
Scratch
Fix Released
High
Viko Adi Rahmawan

Bug Description

The Fullscreen button hides the HeaderBar for some reason.

Related branches

Daniel Fore (danrabbit) on 2014-03-08
Changed in scratch:
milestone: none → isis-beta1
Changed in scratch:
importance: Undecided → Low
status: New → Confirmed
Cameron Norman (cameronnemo) wrote :

I think this is a problem at the window manager level, because when I use the fullscreen window shortcut (I have it configured to alt + f, do not know the default), it dissappears in Maya and Noise.

Changed in maya:
status: New → Confirmed
Cameron Norman (cameronnemo) wrote :

Also, since you can fullscreen a window with a WM shortcut, removing the in app keyboard shortcut and menu option (like with Noise) is not that great a solution.

Daniel Fore (danrabbit) wrote :

Shortcuts aren't really an issue since we can assume of someone knows the shortcut they'll be able to get out of fullscreen. The concern is more for people that don't know about the keyboard shortcuts.

Cody Garver (codygarver) on 2014-04-12
Changed in scratch:
importance: Low → Medium
Changed in maya:
importance: Undecided → Medium
milestone: none → isis-beta1
Daniel Fore (danrabbit) wrote :

The Maya I see here doesn't have fullscreen in the menu so marking as fixed for Maya

Changed in maya:
status: Confirmed → Fix Committed

Bumping priority to High because this bug can completely lock the system for anyone who doesn't remember the keyboard shortcuts.

Changed in scratch:
importance: Medium → High
Jacob Parker (jacobparker1992) wrote :

Would it make sense to remove this fullscreen feature entirely? With the headerbar, the space is saved anyway, and having it only adds clutter to the gear menu.

Jacob Parker (jacobparker1992) wrote :

I'll also add, if somebody accidentally clicks it, they'll have no idea how to recover. It just seems like a hindrance over anything.

Changed in noise:
status: New → Incomplete
Daniel Fore (danrabbit) on 2014-05-29
Changed in noise:
status: Incomplete → Fix Committed
milestone: none → isis-beta2
milestone: isis-beta2 → none
status: Fix Committed → Fix Released

There's no Fullscreen button in the current Isis version of Noise and F11 does nothing. Marking incomplete for Noise.

Jacob Parker (jacobparker1992) wrote :

Sorry, that's my bad. I remembered it was like that a few weeks ago. I'll add, Scratch will then be the only elementary application to have this feature.

Robert Roth (evfool) wrote :

gEdit solves this by replicating the toolbar in a revealer, and in case of moving the mouse to the top of the screen, showing the revealer contents. This is a bit of code duplication, it might be worth having something like this in Gtk+ for fullscreen windows, but until we will have it, we could do the same as gedit. Any objections?

Daniel Fore (danrabbit) wrote :

Yeah that's probably a good compromise

Robert Roth (evfool) on 2014-05-30
Changed in scratch:
assignee: nobody → Robert Roth (evfool)
Robert Roth (evfool) on 2014-06-01
Changed in scratch:
assignee: Robert Roth (evfool) → nobody
Daniel Fore (danrabbit) on 2014-06-03
Changed in maya:
status: Fix Committed → Fix Released
Robert Roth (evfool) wrote :
summary: - Unable to access HeaderBar in fullscreen
+ Unable to access HeaderBar in fullscreen [$15]
Viko Adi Rahmawan (vikoadi) wrote :

in my branch, provide toolbar in revealer,
toolbar hooking still doesnt work
restoring in fullscreen mode also doesnt work

Changed in scratch:
assignee: nobody → Viko Adi Rahmawan (vikoadi)
Viko Adi Rahmawan (vikoadi) wrote :

should be working now

Changed in scratch:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2014-07-09
Changed in scratch:
assignee: Viko Adi Rahmawan (vikoadi) → Cody Garver (codygarver)
status: In Progress → Fix Released
Cody Garver (codygarver) on 2014-07-09
Changed in scratch:
assignee: Cody Garver (codygarver) → Viko Adi Rahmawan (vikoadi)
status: Fix Released → In Progress
Cody Garver (codygarver) on 2014-07-12
Changed in scratch:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers