scratch asks me to wait while it restores last session when welcome screen is set to show on open

Bug #1202886 reported by Kingsley
116
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Scratch
Fix Released
Medium
Mario Guerriero

Bug Description

When I open scratch, or open a file in scratch, it shows the "Wait while restoring last session" message forever. I can still interact with the application while it shows this.

Image attached of me opening and editing a file while it behaves this way.

Revision history for this message
Kingsley (kingsquee) wrote :
description: updated
Revision history for this message
Cameron Norman (cameronnemo) wrote :

WORKAROUND: If you go into preferences and change the behaviour on open to "Open last open tabs", then this does not appear.

Changed in scratch:
status: New → Confirmed
summary: - scratch asks me to wait forever while it restores last session
+ scratch asks me to wait while it restores last session when welcome
+ screen is set to show on open
Revision history for this message
Mario Guerriero (mefrio-g) wrote :

can you post the output of the command "dpkg -s scratch-text-editor"?

no longer affects: elementaryos
Changed in scratch:
status: Confirmed → Incomplete
milestone: none → 2.1
importance: Undecided → Medium
assignee: nobody → Mario Guerriero (mefrio-g)
status: Incomplete → Confirmed
status: Confirmed → Fix Released
Revision history for this message
Mario Guerriero (mefrio-g) wrote :

ouch I made the commit on my pc but I forgot to push :P

Revision history for this message
Siniša Perović (sinisa-p) wrote :

Thanx Mario but I think you've pushed it into the Daily repo. From today we're happy to use Elementary OS Stable PPA ;-)

Revision history for this message
Kingsley (kingsquee) wrote :

@Mario :)

Package: scratch-text-editor
Status: install ok installed
Priority: optional
Section: editors
Installed-Size: 1995
Maintainer: Mario Guerriero <email address hidden>
Architecture: i386
Version: 2.0~r1145-0+pkg49~precise1
Depends: dconf-gsettings-backend | gsettings-backend, libc6 (>= 2.2), libgdk-pixbuf2.0-0 (>= 2.22.0), libgee2 (>= 0.5.0), libglib2.0-0 (>= 2.31.8), libgranite1 (>= 0.2.0~), libgtk-3-0 (>= 3.1.6), libgtksourceview-3.0-0 (>= 2.91.4), libgtkspell-3-0, libpango1.0-0 (>= 1.14.0), libpeas-1.0-0 (>= 1.1.0), libsoup2.4-1 (>= 2.4.0), libvala-0.18-0 (>= 0.17.1), libvte-2.90-9 (>= 1:0.27.90), libwebkitgtk-3.0-0 (>= 1.3.10), libzeitgeist-1.0-1 (>= 0.3.14)
Description: text editor written in Vala
 Scratch is the text editor that works for you. It auto-saves your files,
 meaning they're always up-to-date. Plus it remembers your tabs so you never
 lose your spot, even in between sessions.
 .
 Make it yours. Scratch is written from the ground up to be extensible. Keep
 things super lightweight and simple, or install extensions to turn Scratch
 into a full-blown IDE; it's your choice. And with a handful of useful
 preferences, you can tweak the behavior and interface to your liking.
 .
 It's elementary. Scratch is made to be the perfect text editor for elementary,
 meaning it closely follows the high standards of design, speed, and
 consistency. It's sexy, but not distracting.
 .
 Works with your language. Whether you're crafting code in Vala, scripting with
 PHP, or marking things up in HTML, Scratch has you covered. Experience full
 syntax highlighting with nearly all programming, scripting, and markup
 languages.
 .
 Other syntax-highlighted languages: Bash, C, C#, C++. Cmake, CSS, .Desktop,
 Diff, Fortran, Gettext, ini, Java, JavaScript, LaTex, Lua, Makefile,
 Objective C, Pascal, Perl, Python, Ruby, XML.
Homepage: http://launchpad.net/scratch

Revision history for this message
Cody Garver (codygarver) wrote :

The stable PPA will not get this unreleased version of scratch, you will be automatically downgraded to 2.0 soon.

Revision history for this message
Mario Guerriero (mefrio-g) wrote :

Cody do I need to make a release?

Revision history for this message
Cody Garver (codygarver) wrote : Re: [Bug 1202886] Re: scratch asks me to wait while it restores last session when welcome screen is set to show on open

I think you should because the 2.1 milestone is too big, but it's not
necessary if its inconvenient.

Sent from my iPhone

On Jul 21, 2013, at 3:50 PM, Mario Guerriero <email address hidden> wrote:

> Cody do I need to make a release?
>
> --
> You received this bug notification because you are subscribed to
> elementary.
> https://bugs.launchpad.net/bugs/1202886
>
> Title:
> scratch asks me to wait while it restores last session when welcome
> screen is set to show on open
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/scratch/+bug/1202886/+subscriptions

Revision history for this message
Alexander Borisov (aaborisov) wrote :

You can open dconf-editor and go to:
org -> pantheon -> scratch -> settings
and change the value of "opened-files" field. There is list of files that scratch tries to open. And it probably that one of them has too big size. You have just to remove this file from list and relaunch scratch.

Revision history for this message
Mohd Hafizul Afifi Abdullah (hafizul94) wrote :

The same bug occurs to me, but executing this command fixes the problem:

Command:
gsettings set org.pantheon.scratch.settings show-at-start welcome

Source:
https://elementaryos.stackexchange.com/questions/3956/how-can-i-clear-currently-opened-files-in-scratch/3957#3957

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers