Pretends everything is OK when fails to save file

Bug #1007265 reported by Sergey "Shnatsel" Davidoff on 2012-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Scratch
Fix Released
High
Unassigned

Bug Description

When Scratch fails to save a file, e.g. because the user doesn't have permissions to write to the specified folder, Scratch pretends that the file was saved.

tags: added: data-loss
Mario Guerriero (mefrio-g) wrote :

What revision of scratch are you using? It was fixed a lot of time ago. Scratch now doesn't let the user to save a file on which he doesn't have the requested permissions

1.1-0~r730+pkg17~precise1

Mario Guerriero (mefrio-g) wrote :

If you have autosave on, the files with no permissions are not editable. When you have autosave off the files with no permissions can't be saved because the save button is insensitive. Can you explain me what of this two cases have you?

It's about initial save with autosave on.

Changed in scratch:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.1
milestone: 1.1 → luna-beta1
Changed in scratch:
status: Confirmed → Won't Fix
status: Won't Fix → Fix Committed
Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers