Commonizing attributes in a group breaks referencing elements

Bug #603988 reported by Louis Simard on 2010-07-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Scour
Medium
codedread

Bug Description

The file fulltests/git-cola-icons.svg, originally from Ubuntu 10.04's /usr/share/app-install/icons/_usr_share_git-cola_icons_git.svg and added to trunk revision 181, renders incorrectly after being Scoured.

-- To reproduce --

Program version: trunk revision 180

Command line: ./scour.py --shorten-ids --enable-id-stripping --create-groups --renderer-workaround --indent=none -i fulltests/git-cola-icons.svg -o fulltests/git-cola-icons.opt.svg

Changed in scour:
importance: Undecided → Medium
codedread (codedread) wrote :

The problem is this:

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
 <g>
  <rect id="r" width="200" height="100" fill="green"/>
</g>
  <use xlink:href="#r" x="300"/>
</svg>

gets transformed into this:

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
 <g fill="green">
  <rect id="r" width="200" height="100" />
</g>
  <use xlink:href="#r" x="300"/>
</svg>

And the green fill value is not propagated to the <use>.

codedread (codedread) wrote :

Fixed in revision 182.

summary: - Bad render: fulltests/git-cola-icons.svg
+ Commonizing attributes in a group breaks referencing elements
Changed in scour:
status: New → Fix Committed
assignee: nobody → codedread (codedread)
codedread (codedread) on 2010-07-12
Changed in scour:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers