Viewbox option doesn't work when units are set

Bug #576958 reported by jazzynico on 2010-05-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico
Scour
Low
Unassigned

Bug Description

Hi,

I'm trying to scour an SVG file containing units in height and width attributes (in my case, mm), and these attributes are not replaced with a viewbox. Removing the unit resolves this issue. Could you add unit support for the viewbox?

Thanks!

Related branches

jazzynico (jazzynico) wrote :
Changed in inkscape:
importance: Undecided → Low

It looks like librsvg does not handle viewBox coordinates with units so well; in fact, your test file renders absolutely nothing if I change

width="210mm" height="297mm"

to

viewBox="0 0 210mm 297mm"

. Firefox does handle it, though, and so will Inkscape I suppose. :)

Changed in scour:
importance: Undecided → Low
status: New → Confirmed

A fix for this bug has been committed into lp:scour, revision 175.

It's enabled only with renderer workarounds disabled, since librsvg/Eye of GNOME demand pixels.

Changed in scour:
status: Confirmed → Fix Committed
jazzynico (jazzynico) wrote :

Thanks for the fix, Louis!

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: New → In Progress
codedread (codedread) on 2010-07-12
Changed in scour:
status: Fix Committed → Fix Released
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 10180.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers