Incomplete/incorrect entries in LaTeX table

Bug #295434 reported by Plareplane on 2008-11-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SCIM
Unknown
Unknown
scim-tables (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

The current LaTeX table is not very comprehensive, and some symbols are incorrect as well (for example ⊤ is associated with \bot!). I have modified my local copy using data from Will Robertson's unicode-math.tex. Will it be possible to push this to Debian or even further upstream?

Plareplane (plareplane) on 2008-11-08
description: updated
Plareplane (plareplane) wrote :

I converted unicode-math.tex into scim table format and manually added the few symbols that were in the old LaTeX.txt.in but not unicode-math.tex.

Plareplane (plareplane) wrote :

I expand the description, the correct associatation is
\top ⊤
\bot ⊥ (for bottom)

LI Daobing (lidaobing) on 2009-04-04
Changed in scim-tables (Ubuntu):
assignee: nobody → lidaobing
status: New → Confirmed
LI Daobing (lidaobing) wrote :

the \top and \bot bug is reported to upstream as bug sf#2730018

the new LaTeX.txt.in is reported to upstream as bug sf#2730024: http://sourceforge.net/support/tracker.php?aid=2730024

Rolf Leggewie (r0lf) wrote :

The upstream ticket is marked as closed. Is there anything left to be done here?

Changed in scim-tables (Ubuntu):
status: Confirmed → Incomplete

On my 14.04 LTS ubuntu Laptop, \bot still gives “⊤” . I have the version 0.5.13-1ubuntu1 (see below), which, I think, is the latest version available on Trusty/

fred@zeno~$ apt show scim-tables-additional |head -8

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

Package: scim-tables-additional
Priority: optional
Section: universe/utils
Installed-Size: 229 kB
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Tz-Huan Huang <email address hidden>
Source: scim-tables
Version: 0.5.13-1ubuntu1

Rolf Leggewie (r0lf) wrote :

I don't think it's fixed even in the latest release. But would you be so kind to test?

Changed in scim-tables (Ubuntu):
assignee: LI Daobing (lidaobing) → Rolf Leggewie (r0lf)
status: Incomplete → Triaged

A previous Ubuntu upgrade made me change from SCIM to iBus, so I can’t really test.
I did not manage to reinstall SCIM on 17.04. However, looking into the the file /usr/share/scim/tables/LaTeX.bin leads me to the conclusion that \bot and \top are now correct (for scim-tables-additional/zesty,zesty,now 0.5.14-1build1 )

Rolf Leggewie (r0lf) wrote :

You are having problems to install scim? That's odd. Can you elaborate?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.