Unrecognized day id error on localized XLS import

Bug #901267 reported by silvagomes93 on 2011-12-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
SchoolTool
Critical
Gediminas Paulauskas
2.1
High
Gediminas Paulauskas

Bug Description

Using Ubuntu 11.04, Firefox 8.0, Portuguese-Br language

Gediminas Paulauskas (menesis) wrote :

True, I cannot import one school xls, where "Same day each week" timetable is used.

tags: added: i18n import
tags: added: xls
Changed in schooltool:
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → High
Tom Hoffman (tom-hoffman) wrote :

Timely!

Changed in schooltool:
assignee: nobody → Douglas Cerna (replaceafill)
milestone: none → 2.1
Tom Hoffman (tom-hoffman) wrote :

I'm assigning this to replaceafill assuming that i18n has something to do with it. If it is just a generic import bug and alan or justas has more experience with these bugs, it can be reassigned to them (and pushed to a bugfix release).

Changed in schooltool:
assignee: Douglas Cerna (replaceafill) → Alan Elkner (aelkner)
importance: High → Critical
milestone: 2.1.0 → next
Changed in schooltool:
importance: Critical → High
assignee: Alan Elkner (aelkner) → Douglas Cerna (replaceafill)
Changed in schooltool:
importance: High → Critical
Tom Hoffman (tom-hoffman) wrote :

So... is this bug just because Douglas switched the exporter to be translated but the importer isn't?

Douglas Cerna (replaceafill) wrote :

Not guilty! Never touched the timetable exporter :)

It's not even the exporter who makes the translation. The translation is made when the timetable is created through the web:

schooltool.timetable.browser.ttwizard module, line 296:

            weekday_names = [translate(day_of_week_names[i],
                                       context=self.request)
                             for i in range(7)]
            session['day_names'] = weekday_names

The day templates have their title set to the translated string and the exporter just uses those.

Gediminas Paulauskas (menesis) wrote :

Workaround: replace week day names with english ones (Monday, Tuesday...), or delete the School Timetables sheet.

Changed in schooltool:
milestone: next → 2.1.1
summary: - Importing xls, portuguese days id not recognized, example:
- "Unrecognised day id Terça-Feira "
+ Unrecognized day id error on localized XLS import
Changed in schooltool:
milestone: 2.1.1 → 2.1.3
Changed in schooltool:
assignee: Douglas Cerna (replaceafill) → Gediminas Paulauskas (menesis)
milestone: 2.1.3 → 2.1.2
status: Confirmed → Fix Committed
Changed in schooltool:
milestone: 2.1.2 → 2.2.2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers