i18n translation domain is registered wrong in ftests

Bug #622615 reported by Justas Sadzevičius
This bug report is a duplicate of:  Bug #79761: locale-independent unit tests. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool
High
Douglas Cerna

Bug Description

Functional test setup should not include any ZCMLs that have <registerTranslations ...> directive.

They should:
  <utility
      component="zope.i18n.testmessagecatalog.TestMessageFallbackDomain"
      />

Currently translation registration screws up tests if somebody compiles their translations.

Changed in schooltool:
importance: Undecided → High
Changed in schooltool:
status: New → Confirmed
Revision history for this message
Tom Hoffman (tom-hoffman) wrote :

Is this fixed?

Changed in schooltool:
assignee: nobody → Douglas Cerna (replaceafill)
milestone: none → 1.5.2
Changed in schooltool:
assignee: Douglas Cerna (replaceafill) → Justas Sadzevičius (justas-pov)
milestone: 1.5.2 → next
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

Only tests for schooltool.app.main that run StandaloneServer have translated output, and that happens because main.py module sets up localization itself (defines the _ symbol), not because translations are registered by ftesting.zcml.

Changed in schooltool:
assignee: Justas Sadzevičius (justas-pov) → Douglas Cerna (replaceafill)
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

as explained in comment #2, 'domain is registered wrong in ftests' is not the reason for test failures that we were getting. I have fixed the bug for 1.6.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers