Set up automatic translations import

Reported by Gediminas Paulauskas on 2009-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool
Medium
Gediminas Paulauskas

Bug Description

Currently there are three templates:

template branch # of messages
------------------------- ------------------------- -------------
schooltool schooltool 1010
schooltool.commendation schooltool 21
schooltool.lyceum.journal schooltool.lyceum.journal 31

This setup requires manual work - uploading the templates, downloading
and uploading translations. With recent improvements to launchpad
(see http://blog.launchpad.net/translations/import-translations-from-bazaar-branches )
part of this can be automated - specifically automatic import of templates
and translations from the branch. But we cannot do that if we have
several templates, and especially lyceum.journal which is a different branch
and cannot be monitored by launchpad.

The number of strings in those extra templates is very small compared to
the main template, so this separation brings little benefit for much
manual work and confusion for translators.

Moreover, we already pull schooltool.gradebook messages into main template,
so we can do the same with lyceum.journal

tags: added: i18n
removed: translations
Gediminas Paulauskas (menesis) wrote :

I will move lyceum.journal into a separate launchpad project, but also split out gradebook messages, because gradebook will also become a top-level project.

Not sure what to do with commendation, maybe make it a separate example package, because that's what it is.

To make full use of Launchpad Translations there has to be a single template per project. Moreover, it has to be hosted on Launchpad Code.

Tom Hoffman (tom-hoffman) wrote :

We need to discuss this on Monday.

Changed in schooltool:
milestone: none → karmic
summary: - Merge translation templates into one
+ Set up automatic translations import
Changed in schooltool:
status: Confirmed → Fix Released
milestone: karmic → 1.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers