Broken urls in help window when application URL is not /

Bug #372606 reported by mkaz on 2009-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool
Low
Gediminas Paulauskas

Bug Description

If the application is served from apache in WSGI and application URL path is not / e.g. http://school.edu/schooltool/ then the links/urls in the help window are broken. It does not have application URL in it. e.g.
Broken link: http://school.edu/++help++/schooltool/calendaring
when the correct url should be
http://school.edu/schooltool/++help++/schooltool/calendaring

Version tested 1.0

Steps to reproduce
1. Serve schooltool thru WSGI at http://server/schooltool/
2. Login to school tool
3. Click on the help link on the right corner
4. When the help window pops up click on any topic links to the left.

Result: Page not found
Expected Result: Display help information in the help window.

I have a patch for this problem which is attached.

There is some addition problem rendering + and - images in the help topic tree. That problem seems to be in tree.css of zope distribution.

mkaz (mubashir-kazia) wrote :
Tom Hoffman (tom-hoffman) wrote :

Thanks for the patch.

Also, I'm not sure if anyone else on the project has run SchoolTool under WSGI yet. I may hit you up for some advice on that, since it has some clear advantages.

Changed in schooltool:
assignee: nobody → Justas Sadzevičius (justas-pov)
importance: Undecided → Medium
status: New → In Progress
Changed in schooltool:
milestone: none → karmic
Changed in schooltool:
milestone: lucid → 1.2.0
Changed in schooltool:
milestone: 1.2.0 → 1.2.1
Changed in schooltool:
status: In Progress → Fix Committed
assignee: Justas Sadzevičius (justas-pov) → Gediminas Paulauskas (menesis)
importance: Medium → Low
Changed in schooltool:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers