Server won't start

Bug #334365 reported by Phillip Tarrant on 2009-02-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool
High
Gediminas Paulauskas

Bug Description

tried to do a backup of the data on the schooltool machine and followed the directions on the site.
I stopped the server using /etc/init.d/schooltool-2008 stop
I tried to copy the fs file...no go.
Tried a reboot and now the server won't start
I tried running /etc/init.d/schooltool-2008 start and this is what i get

 * Starting SchoolTool 2008...
Traceback (most recent call last):
  File "/usr/bin/paster", line 17, in ?
    from paste.script import command
ImportError: No module named paste.script [fail]

Tom Hoffman (tom-hoffman) wrote :

What do you mean "no go" on the copy?

ok, nm, while trying to re-create the issue that part worked. i can now copy
the .fs files
im still getting the ImportError: No module named paste.script issue though

On Wed, Feb 25, 2009 at 9:49 AM, Tom Hoffman <email address hidden> wrote:

> What do you mean "no go" on the copy?
>
> --
> Server won't start
> https://bugs.launchpad.net/bugs/334365
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SchoolTool: New
>
> Bug description:
>
> tried to do a backup of the data on the schooltool machine and followed the
> directions on the site.
> I stopped the server using /etc/init.d/schooltool-2008 stop
> I tried to copy the fs file...no go.
> Tried a reboot and now the server won't start
> I tried running /etc/init.d/schooltool-2008 start and this is what i get
>
> * Starting SchoolTool 2008...
> Traceback (most recent call last):
> File "/usr/bin/paster", line 17, in ?
> from paste.script import command
> ImportError: No module named paste.script
> [fail]
>

--
Thanks,
Phillip Tarrant

>>> CONFIDENTIALITY NOTICE <<<
This electronic mail message, including any and/or all attachments, is for
the sole use
of the intended recipient(s), and may contain confidential and/or privileged
information,
pertaining to business conducted under the direction and supervision of
Phillip J Tarrant.
Unauthorized interception, review, use, disclosure or distribution of any
such information
contained within this electronic mail message and/or its attachment(s),
is(are) strictly
prohibited. If you are not the intended recipient, please contact the sender
by replying
to this electronic mail message, along with the destruction all copies and
originals of the original electronic mail message (along with any
attachments).

Phillip Tarrant (ptarrant) wrote :

while trying to recreate the error all worked well on the file copy, however the server is still saying "importerror" when i try to start it. perhaps i was typing the cp syntax wrong (most likely)

i was originally getting a "file not found" error on the schooltool-2008-Data.fs however i could see it if i did a sudo ls...but a sudo cp didn't touch it and was giving me the file not found.

Tom Hoffman (tom-hoffman) wrote :

Try:

sudo apt-get install python-paste python-pastescript

And start the server again.

Phillip Tarrant (ptarrant) wrote :

they are already installed and at the newest version

On Wed, Feb 25, 2009 at 10:21 AM, Tom Hoffman <email address hidden> wrote:

> Try:
>
> sudo apt-get install python-paste python-pastescript
>
> And start the server again.
>
> --
> Server won't start
> https://bugs.launchpad.net/bugs/334365
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SchoolTool: New
>
> Bug description:
>
> tried to do a backup of the data on the schooltool machine and followed the
> directions on the site.
> I stopped the server using /etc/init.d/schooltool-2008 stop
> I tried to copy the fs file...no go.
> Tried a reboot and now the server won't start
> I tried running /etc/init.d/schooltool-2008 start and this is what i get
>
> * Starting SchoolTool 2008...
> Traceback (most recent call last):
> File "/usr/bin/paster", line 17, in ?
> from paste.script import command
> ImportError: No module named paste.script
> [fail]
>

--
Thanks,
Phillip Tarrant

>>> CONFIDENTIALITY NOTICE <<<
This electronic mail message, including any and/or all attachments, is for
the sole use
of the intended recipient(s), and may contain confidential and/or privileged
information,
pertaining to business conducted under the direction and supervision of
Phillip J Tarrant.
Unauthorized interception, review, use, disclosure or distribution of any
such information
contained within this electronic mail message and/or its attachment(s),
is(are) strictly
prohibited. If you are not the intended recipient, please contact the sender
by replying
to this electronic mail message, along with the destruction of all copies
and
originals of the original electronic mail message (along with any
attachments).

Phillip Tarrant (ptarrant) wrote :

I tried the following just for giggles:
Sudo apt-get update
sudo apt-get remove schooltool-2008
sudo apt-get install schooltool-2008

this is the output:
update-rc.d: warning: /etc/init.d/schooltool-2008 missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
 * Starting SchoolTool 2008...
Traceback (most recent call last):
  File "/usr/bin/paster", line 17, in ?
    from paste.script import command
ImportError: No module named paste.script [fail]
invoke-rc.d: initscript schooltool-2008, action "start" failed.
dpkg: error processing schooltool-2008 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 schooltool-2008
E: Sub-process /usr/bin/dpkg returned an error code (1)

I then tried this:
sudo apt-get --purge autoremove schooltool-2008 *(its a test machine, lets get rid of EVERYTHING!)*
sudo apt-get install schooltool-2008

I then get this for the output (*note* this is trimmed from all the "install stuff")
Setting up schooltool-2008 (2) ...
update-rc.d: warning: /etc/init.d/schooltool-2008 missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
 * Starting SchoolTool 2008... Traceback (most recent call last):
  File "/usr/bin/paster", line 17, in ?
    from paste.script import command
ImportError: No module named paste.script [fail]
invoke-rc.d: initscript schooltool-2008, action "start" failed.
dpkg: error processing schooltool-2008 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 schooltool-2008
E: Sub-process /usr/bin/dpkg returned an error code (1)

Perhaps this helps abit, because at this point I'm at a loss :(

Tom Hoffman (tom-hoffman) wrote :

OK... we'll work on this next week. Clearly this is the kind of thing we'll need to be able to cope with quickly once people are in production. ;-)

Ignas Mikalajūnas (ignas) wrote :

I would like you to do this:

post the output of

apt-cache policy python-paste
apt-cache policy python-pastescript

contents of /usr/bin/paster

Oh - and which release of ubuntu is this? Hardy, Intrepid, Jaunty?

Thanks in advance.

Phillip Tarrant (ptarrant) wrote :

It's jaunty alpha 5

*apt-cache policy python-paste*
python-paste:
  Installed: 1.7.1-1
  Candidate: 1.7.1-1
  Version table:
 *** 1.7.1-1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

*apt-cache policy python-pastescript*
python-pastescript:
  Installed: 1.6.3-1
  Candidate: 1.6.3-1
  Version table:
 *** 1.6.3-1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

*cat /usr/bin/paster*
#!/usr/bin/env python
import os
import sys

try:
    here = __file__
except NameError:
    # Python 2.2
    here = sys.argv[0]

relative_paste = os.path.join(
    os.path.dirname(os.path.dirname(os.path.abspath(here))), 'paste')

if os.path.exists(relative_paste):
    sys.path.insert(0, os.path.dirname(relative_paste))

from paste.script import command
command.run()

On Fri, Feb 27, 2009 at 1:05 PM, Ignas Mikalajūnas <email address hidden> wrote:

> I would like you to do this:
>
> post the output of
>
> apt-cache policy python-paste
> apt-cache policy python-pastescript
>
> contents of /usr/bin/paster
>
> Oh - and which release of ubuntu is this? Hardy, Intrepid, Jaunty?
>
> Thanks in advance.
>
> --
> Server won't start
> https://bugs.launchpad.net/bugs/334365
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SchoolTool: New
>
> Bug description:
>
> tried to do a backup of the data on the schooltool machine and followed the
> directions on the site.
> I stopped the server using /etc/init.d/schooltool-2008 stop
> I tried to copy the fs file...no go.
> Tried a reboot and now the server won't start
> I tried running /etc/init.d/schooltool-2008 start and this is what i get
>
> * Starting SchoolTool 2008...
> Traceback (most recent call last):
> File "/usr/bin/paster", line 17, in ?
> from paste.script import command
> ImportError: No module named paste.script
> [fail]
>

Tom Hoffman (tom-hoffman) wrote :

It has been jaunty all along?

Ignas Mikalajūnas (ignas) wrote :

Hmm, can you try:

python --version
python2.5 /usr/bin/paster
python2.4 /usr/bin/paster

Phillip Tarrant (ptarrant) wrote :

Will update monday

and it wasn't jaunty from the getgo. it was intrepid 8.10 however, i tried
installing jaunty to see if that would correct the issue..sadly it didn't
i understand jaunty isn't supported, however this is the same issue from
8.10.

On Fri, Feb 27, 2009 at 2:04 PM, Ignas Mikalajūnas <email address hidden> wrote:

> Hmm, can you try:
>
> python --version
> python2.5 /usr/bin/paster
> python2.4 /usr/bin/paster
>
> --
> Server won't start
> https://bugs.launchpad.net/bugs/334365
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SchoolTool: New
>
> Bug description:
>
> tried to do a backup of the data on the schooltool machine and followed the
> directions on the site.
> I stopped the server using /etc/init.d/schooltool-2008 stop
> I tried to copy the fs file...no go.
> Tried a reboot and now the server won't start
> I tried running /etc/init.d/schooltool-2008 start and this is what i get
>
> * Starting SchoolTool 2008...
> Traceback (most recent call last):
> File "/usr/bin/paster", line 17, in ?
> from paste.script import command
> ImportError: No module named paste.script
> [fail]
>

--
Thanks,
Phillip Tarrant

>>> CONFIDENTIALITY NOTICE <<<
This electronic mail message, including any and/or all attachments, is for
the sole use
of the intended recipient(s), and may contain confidential and/or privileged
information,
pertaining to business conducted under the direction and supervision of
Phillip J Tarrant.
Unauthorized interception, review, use, disclosure or distribution of any
such information
contained within this electronic mail message and/or its attachment(s),
is(are) strictly
prohibited. If you are not the intended recipient, please contact the sender
by replying
to this electronic mail message, along with the destruction of all copies
and
originals of the original electronic mail message (along with any
attachments).

Phillip Tarrant (ptarrant) wrote :
Download full text (4.1 KiB)

we where out of school monday because of snow (in georgia we run scared at
1/4 inch of snow)
here is the promised update

$python --version
Python 2.5.4

$python2.5 /usr/bin/paster
Usage: /usr/bin/paster COMMAND
Usage: paster [paster_options] COMMAND [command_options]

Options:
  --version show program's version number and exit
  --plugin=PLUGINS Add a plugin to the list of commands (plugins are Egg
                    specs; will also require() the Egg)
  -h, --help Show this help message

Commands:
  create Create the file layout for a Python distribution
  help Display help
  make-config Install a package and create a fresh config file/directory
  points Show information about entry points
  post Run a request for the described application
  request Run a request for the described application
  serve Serve the described application
  setup-app Setup an application, given a config file

$ python2.4 /usr/bin/paster
Traceback (most recent call last):
  File "/usr/bin/paster", line 17, in ?
    from paste.script import command
ImportError: No module named paste.script

it would appear you now know where the problem is? :)
just for giggles i did the --version on paster using python2.5 command

python2.5 /usr/bin/paster --version
PasteScript 1.6.3 from /var/lib/python-support/python2.5 (python 2.5.4
(r254:67916, Feb 19 2009, 13:04:55))

2009/2/27 Phillip Tarrant <email address hidden>

> Will update monday
>
> and it wasn't jaunty from the getgo. it was intrepid 8.10 however, i tried
> installing jaunty to see if that would correct the issue..sadly it didn't
> i understand jaunty isn't supported, however this is the same issue from
> 8.10.
>
>
> On Fri, Feb 27, 2009 at 2:04 PM, Ignas Mikalajūnas <email address hidden> wrote:
>
>> Hmm, can you try:
>>
>> python --version
>> python2.5 /usr/bin/paster
>> python2.4 /usr/bin/paster
>>
>> --
>> Server won't start
>> https://bugs.launchpad.net/bugs/334365
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in SchoolTool: New
>>
>> Bug description:
>>
>> tried to do a backup of the data on the schooltool machine and followed
>> the directions on the site.
>> I stopped the server using /etc/init.d/schooltool-2008 stop
>> I tried to copy the fs file...no go.
>> Tried a reboot and now the server won't start
>> I tried running /etc/init.d/schooltool-2008 start and this is what i get
>>
>> * Starting SchoolTool 2008...
>> Traceback (most recent call last):
>> File "/usr/bin/paster", line 17, in ?
>> from paste.script import command
>> ImportError: No module named paste.script
>> [fail]
>>
>
>
>
> --
> Thanks,
> Phillip Tarrant
>
> >>> CONFIDENTIALITY NOTICE <<<
> This electronic mail message, including any and/or all attachments, is for
> the sole use
> of the intended recipient(s), and may contain confidential and/or
> privileged information,
> pertaining to business conducted under the direction and supervision of
> Phillip J Tarrant.
> Unauthorized interception, review, use, disclosure or distribution of any
> such information
> contained within this electronic mail message and/or its attachment(...

Read more...

Tom Hoffman (tom-hoffman) wrote :

We need an instance of this bug on a clean Intrepid system.

Changed in schooltool:
status: New → Incomplete
Changed in schooltool:
importance: Undecided → High
Gediminas Paulauskas (menesis) wrote :

There was a problem with python-paste not available for python2.5 - bug #361163 which was fixed.
And another bug in schooltool-common which tried to use unsupported python2.4 on jaunty, which was also fixed.
So this bug should not occur any more.

Changed in schooltool:
milestone: none → jaunty
status: Incomplete → Fix Released
Tom Hoffman (tom-hoffman) wrote :

This still seems to come up in its less severe form where you get an error message on install but a subsequent manual start works. See https://answers.edge.launchpad.net/schooltool/+question/69880

Changed in schooltool:
assignee: nobody → Gediminas Paulauskas (menesis)
status: Fix Released → Incomplete
Gediminas Paulauskas (menesis) wrote :

Fixed in python-schooltool (2009.04.15-1)
Now schooltool server is (re)started only once, after all dependencies have finished to install.

Changed in schooltool:
status: Incomplete → Fix Released
Changed in schooltool:
milestone: jaunty → 2009.4.13
Gediminas Paulauskas (menesis) wrote :

It still does not start on `apt-get install schooltool-2009` with the same error. At least on jaunty 64bit

Changed in schooltool:
milestone: 2009.4.16 → august-1
status: Fix Released → In Progress
Gediminas Paulauskas (menesis) wrote :

schooltool-common (6ubuntu2) hardy; urgency=low

  * Pre-Depends on python-pastescript (LP: #334365)

 -- Gediminas Paulauskas <email address hidden> Wed, 29 Jul 2009 21:00:51 +0300

Changed in schooltool:
status: In Progress → Fix Released
David Ally (david-ally) wrote :

Hi Gediminas,

How was this bug resolved then? I'm running ubuntu 10.04 and I installed several versions of zope, 2.11 and 3.2, 3.4.0 from svn, eggs and buildout, thereafter, I couldn't start the schooltool-cando instance on my laptop. This is the error message I got;

david@ubuntu104:~$ sudo /etc/init.d/schooltool-cando restart
 * Restarting CanDo... Traceback (most recent call last):
  File "/usr/bin/paster", line 17, in ?
    from paste.script import command
ImportError: No module named paste.script
                                                                         [fail]
                                                                         [ OK ]

So, how was this resolved then? I have tried uninstalling and reinstalling schooltool-cando and there is no solution.

And how do i get zope 3.4 installed on my PC for learning how to develop with this tool?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions