could not delete event over link "../timetable-calendar.."

Bug #271391 reported by Daniel Höger on 2008-09-17
2
Affects Status Importance Assigned to Milestone
SchoolTool
Undecided
Justas Sadzevičius

Bug Description

I want to delete an event at the daily view of a person. The section is scheduled over a term and a timetable with other different sections.
When I klick on the "x"-link from the event (see attachment), it appears the "Not Found"-Page.
Deleting event on single event view with "Details" and "Scheduled resources" works.

Steps:
- create Events over existing Sections with a term and a timetable
-> section is weekly on different days and periods
- choose person, who is the instructor of the section, to view the calendar and timetable (daily view)
-> want to delete a Event at one day on one period
- klick on the "x"-link from the event to delete the event
-> "Not Found"-Page

Daniel Höger (hoegerd17) wrote :
description: updated
Tom Hoffman (tom-hoffman) wrote :

I think the fix here is to not allow you to delete the event but to give you a proper message. That is, for most use cases, you don't want teachers to be able to delete class meeting events. Ignas?

Changed in schooltool:
assignee: nobody → ignas
Daniel Höger (hoegerd17) wrote :

If you are locked in with the "manager" account and you want to delete a section event at the same way ( Calendar for Administrator View ), you have the same "Not Found" -page at the end of steps.

Ignas Mikalajūnas (ignas) wrote :

I can't reproduce it in an up to date schooltool. Could you post the URL that gives you the not-found error (the one that X is leading to) like - right click on the X and do - Copy Link location, and then post it here.

Daniel Höger (hoegerd17) wrote :

Steps:
- logged in as "manager"
- created person: testperson
- created term,timetable,course and section
- made a schedule for the section
- testperson is instructor of the section
- select on calender view over "Manage" testperson, to view the calender events of the section
- select on a daily at an event the X - Link, for delete the event
here is the Link:
http://localhost:7080/persons/testperson/timetable-calendar/delete.html?event_id=1107965065-/sections/1/timetables/testterm.default@daniel-desktop&date=2008-11-03

Changed in schooltool:
assignee: Ignas Mikalajūnas (ignas) → Justas Sadzevičius (justas-pov)
status: New → In Progress
Changed in schooltool:
status: In Progress → Fix Committed
Changed in schooltool:
milestone: none → 2009.4.14
Changed in schooltool:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments