Ampersand breaks student detail report

Bug #1328619 reported by Keon Bobb on 2014-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool
High
Douglas Cerna
2.6
High
Gediminas Paulauskas

Bug Description

I get this report when i try downloading student detail reports, it attempts it then fails with this message

System failure. Ticket nr. 821cbfcf-2f7e-4633-939e-746d2aea6187

Tom Hoffman (tom-hoffman) wrote :

Hi Keon,

Please attach the error log and server status as described here: http://book.schooltool.org/troubleshooting.html

Keon Bobb (keon-bobb) wrote :

ID 821cbfcf-2f7e-4633-939e-746d2aea6187
Task pending or removed
Persisted traceback
Exception
xmlParseEntityRef: no name, line 303, column 32
Traceback
File "/usr/lib/python2.7/dist-packages/schooltool/task/tasks.py", line 184, in runTransaction
  result = callable(*args, **kw)
File "/usr/lib/python2.7/dist-packages/schooltool/report/report.py", line 450, in execute
  report_file = self.renderToFile(renderer, *args, **kwargs)
File "/usr/lib/python2.7/dist-packages/schooltool/report/report.py", line 499, in renderToFile
  self.renderReport(renderer, stream, *args, **kw)
File "/usr/lib/python2.7/dist-packages/schooltool/report/report.py", line 543, in renderReport
  pdf = rml2pdf.parseString(rml, filename=filename or None)
File "/usr/lib/python2.7/dist-packages/z3c/rml/rml2pdf.py", line 36, in parseString
  root = etree.fromstring(xml)
File "lxml.etree.pyx", line 2993, in lxml.etree.fromstring (src/lxml/lxml.etree.c:62980)

File "parser.pxi", line 1617, in lxml.etree._parseMemoryDocument (src/lxml/lxml.etree.c:92828)

File "parser.pxi", line 1488, in lxml.etree._parseDoc (src/lxml/lxml.etree.c:91572)

File "parser.pxi", line 969, in lxml.etree._BaseParser._parseUnicodeDoc (src/lxml/lxml.etree.c:87962)

File "parser.pxi", line 577, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:84019)

File "parser.pxi", line 676, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:85122)

File "parser.pxi", line 616, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:84445)

Exception
<ExceptionWithTraceback (XMLSyntaxError(u'xmlParseEntityRef: no name, line 303, column 32',))>
Traceback
File "/usr/lib/python2.7/dist-packages/schooltool/task/tasks.py", line 211, in __call__
  result = self.runTransaction('execute', True, self, *args, **kwargs)
File "/usr/lib/python2.7/dist-packages/schooltool/task/tasks.py", line 201, in runTransaction
  raise failure
Internal state PENDING

Tom Hoffman (tom-hoffman) wrote :

Thanks. We should be able to look at these next week.

Hi tom, any luck with the error code given?

On Fri, Jun 13, 2014 at 10:41 AM, Tom Hoffman <email address hidden> wrote:

> Thanks. We should be able to look at these next week.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1328619
>
> Title:
> student detail report failure
>
> Status in SchoolTool:
> New
>
> Bug description:
> I get this report when i try downloading student detail reports, it
> attempts it then fails with this message
>
> System failure. Ticket nr. 821cbfcf-2f7e-4633-939e-746d2aea6187
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/schooltool/+bug/1328619/+subscriptions
>

Sorry we're a bit swamped Keon... hopefully we'll get to it soon.

Changed in schooltool:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Douglas Cerna (replaceafill)

Hi Tom, I know your probably under some pressure, just giving a friendly
reminder about the errors i'm receiving, and is there any way i can help?

On Mon, Jul 7, 2014 at 4:58 PM, Tom Hoffman <email address hidden> wrote:

> Sorry we're a bit swamped Keon... hopefully we'll get to it soon.
>
> ** Changed in: schooltool
> Status: New => Triaged
>
> ** Changed in: schooltool
> Importance: Undecided => High
>
> ** Changed in: schooltool
> Assignee: (unassigned) => Douglas Cerna (replaceafill)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1328619
>
> Title:
> student detail report failure
>
> Status in SchoolTool:
> Triaged
>
> Bug description:
> I get this report when i try downloading student detail reports, it
> attempts it then fails with this message
>
> System failure. Ticket nr. 821cbfcf-2f7e-4633-939e-746d2aea6187
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/schooltool/+bug/1328619/+subscriptions
>

Hi Keon,

It seems like an ampersand ("&") is triggering this bug, probably in comments. We should be able to fix it soon, but if for some reason you know where the ampersand is, you could try just taking it out.

Douglas Cerna (replaceafill) wrote :

I was able to reproduce this by inserting ampersands in the course titles and the instructor first/last name.

Douglas Cerna (replaceafill) wrote :
Changed in schooltool:
status: Triaged → Fix Committed

Thank you soo much, this worked. The problem is solved!

On Fri, Jul 25, 2014 at 1:38 PM, Douglas Cerna <email address hidden>
wrote:

> Fixed in trunk (http://bazaar.launchpad.net/~schooltool-
> owners/schooltool/trunk/revision/3793)
>
> ** Changed in: schooltool
> Status: Triaged => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1328619
>
> Title:
> student detail report failure
>
> Status in SchoolTool:
> Fix Committed
>
> Bug description:
> I get this report when i try downloading student detail reports, it
> attempts it then fails with this message
>
> System failure. Ticket nr. 821cbfcf-2f7e-4633-939e-746d2aea6187
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/schooltool/+bug/1328619/+subscriptions
>

summary: - student detail report failure
+ Ampersand breaks student detail report
Changed in schooltool:
milestone: none → 2.6.5
Changed in schooltool:
milestone: 2.6.5 → 2.8.1
status: Fix Committed → Fix Released
milestone: 2.8.x → 2.8.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers