Saving attendance/grades does not work

Bug #879425 reported by Justas Sadzevičius on 2011-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool Journal
Critical
Justas Sadzevičius

Bug Description

Tried with freshly imported sample data

Changed in schooltool.lyceum.journal:
milestone: none → 1.9.2
importance: Undecided → Critical
Gediminas Paulauskas (menesis) wrote :

Administrator can enter attendance, but it is not saved.
Teacher's entered attendance is saved.

There was a bug where attendance could not be saved by anyone for months other than first. Caused by journal/gradebook unification.

Changed in schooltool.lyceum.journal:
status: New → Fix Committed
assignee: nobody → Justas Sadzevičius (justas-pov)
Changed in schooltool.lyceum.journal:
status: Fix Committed → Fix Released
Gediminas Paulauskas (menesis) wrote :

This was not fixed.

Click on a month other than first, enter attendance, Save.

You are back to the first month and attendance is not saved.

Changed in schooltool.lyceum.journal:
status: Fix Released → Triaged
milestone: 1.9.2 → 1.9.3
Changed in schooltool.lyceum.journal:
status: Triaged → Fix Committed
Changed in schooltool.lyceum.journal:
status: Fix Committed → Fix Released
no longer affects: schooltool.lyceum.journal (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers