Schooltool intervention message not sent

Bug #942566 reported by Bradley Shank on 2012-02-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool Intervention
High
Alan Elkner

Bug Description

Server email is setup to use gmail as per the documentation. Test mail is sent and received however messages sent through the intervention page are not received (checked the spam and the sent mail for account). No error messages in var/log/schooltool/*

Thanks for your fast response,
Brad

Bradley Shank (tp-6ra2-3w) wrote :

Changed email configuration to use localhost (configures and tested exim4) still does not send mail in message or intervention, send test mail works fine from the email config page.

Changed in schooltool.intervention:
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Alan Elkner (aelkner)
Alan Elkner (aelkner) wrote :

I was able to reproduce the problem, and the short term solution is to make sure that the sender user in schooltool and at least one of the receiver schooltool users has an email address set up in their personal contact information. To set this up, please refer to this page in the schooltool book:

http://book.schooltool.org/contacts.html

and refer to the part where it explains how to access 'Add: Charles Brown as Contact' to get to the page where you can fill in an email address for a user. Again, be sure that the sender user and at least one of the recipient users has this email address set up.

In the meantime, we will update the New Intervention Message page to give an error message when the email addresses are missing.

Tom Hoffman (tom-hoffman) wrote :

So... the problem is nobody had a contact email? Can we add an email icon next to people who have email addresses or something?

Alan Elkner (aelkner) on 2012-03-07
Changed in schooltool.intervention:
status: Triaged → Fix Committed
Changed in schooltool.intervention:
milestone: none → 2.0.2
Changed in schooltool.intervention:
status: Fix Committed → Fix Released
importance: Critical → High
Ole Guldberg (olegb) wrote :

Even though email is working and emailadresses are input I am not able to select wether to send email or not - this is both in the messages part and goals part og Journal. (See attached picture)

olegb@l11:~$ dpkg -s python-schooltool.lyceum.journal
Package: python-schooltool.lyceum.journal
Status: install ok installed
Priority: extra
Section: python
Installed-Size: 1147
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Source: schooltool.lyceum.journal
Version: 2.0.3-0ubuntu1

Ole Guldberg (olegb) wrote :

Sorry for the fuzz - I wasn't logged in as a teacher ... doing that clears up the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers