schooltool failed upon system update

Bug #1259016 reported by mark mcdougall on 2013-12-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool Intervention
Critical
Gediminas Paulauskas

Bug Description

been running 2.6.2dev? on 12.4 LTS
updated two days ago
issue noticed and auto-reported to ubuntu/canonical, immediately again issue noted and auto-reported to ubuntu/canonical,
Ubuntu itself kept running.
this morning schooltool noticed as not working in browser windows.
tried start schooltool in command window (gnome terminal) and said (OK)
but still not accessible??

mark mcdougall (mmcdouga) wrote :

If there were a diagnostics chapter in the schooltool book, codes to run to check different aspects, that might make for less delays for users and less demand on supporters

mark mcdougall (mmcdouga) wrote :

apologies, comment two belongs in another thread
m

Gediminas Paulauskas (menesis) wrote :

To see the status of processes, the command is

$ sudo service schooltool status

The log file is at /var/log/schooltool/error.log

  $ sudo less /var/log/schooltool/error.log

Press End, see if there is a Traceback or some kind of error, copy and paste here. Or attach the whole file for us to examine.

I have not seen the auto-reported bugs. Could you tell me the bug numbers?

There is one regarding reports not being generated, but I have not received any detailed errors from the Scheduled Tasks page, so cannot answer it either https://bugs.launchpad.net/schooltool/+bug/1251966

Changed in schooltool:
status: New → Incomplete
mark mcdougall (mmcdouga) wrote :

Thanks, I should note these commands- could they be put in the book for
 schooltool under diagnostics?
 auto-reported bugs. dont know bug numbers, ubuntu may have reported them to
 canonical, not schooltool?
 commands--$ sudo service schooltool status--gave
 schooltool FATAL Exited too quickly (process log
 may have details)
 services:celery_report RUNNING pid 1256, uptime 0:02:41
 services:redis RUNNING pid 1254, uptime 0:02:41
 services:zeo RUNNING pid 1255, uptime 0:02:41
 command
 get - var/log/schooltool/error.log (END)
 then not sure how to get out of screen?
 tried stopping and restarting, same status message (DIFFERENT TIMES )
 HOPE THIS HELPS,
other bug, I didn't find the error report details? all gone till I get ST up and running though...
 MARK

Gediminas Paulauskas (menesis) wrote :

Unfortunately, the logs have likely been rotated.

Older logs are in the same directory named /var/log/schooltool/error.log.1.gz /var/log/schooltool/error.log.2.gz and so on.

You can view them with 'zless' command, e.g.

  $ sudo zless /var/log/schooltool/error.log.1.gz

Or attach it here.

Gediminas Paulauskas (menesis) wrote :

Note to self: I have found two reports of a failed startup that end with

  File "/usr/lib/python2.7/dist-packages/schooltool/intervention/browser/widgets.py", line 35, in <module>
    from z3c.form.browser.widget import WidgetLayoutSupport
ZopeXMLConfigurationError: File "/etc/schooltool/standard/site.zcml", line 9.2-9.57
    ZopeXMLConfigurationError: File "/usr/lib/python2.7/dist-packages/schooltool/skin/flourish/instance/configure.zcml", line 58.2-58.60
    ZopeXMLConfigurationError: File "/usr/lib/python2.7/dist-packages/schooltool/intervention/plugin.zcml", line 6.2-6.25
    ZopeXMLConfigurationError: File "/usr/lib/python2.7/dist-packages/schooltool/intervention/configure.zcml", line 13.2-13.32
    ZopeXMLConfigurationError: File "/usr/lib/python2.7/dist-packages/schooltool/intervention/browser/configure.zcml", line 296.2-302.8
    ImportError: cannot import name WidgetLayoutSupport

https://errors.ubuntu.com/oops/54ee0a0a-5fd7-11e3-8ad5-e4115b0f8a4a

This would happen on 12.04 only, where z3c.form is older. This can be avoided by uninstalling python-schooltool.intervention

  $ sudo apt-get remove python-schooltool.intervention

Will be fixed in the next round of daily builds.

mark mcdougall (mmcdouga) wrote :

has been fixed and restarted.all fine so far as I can see, thanks

Changed in schooltool:
status: Incomplete → Fix Released
affects: schooltool → schooltool.intervention
Changed in schooltool.intervention:
assignee: nobody → Gediminas Paulauskas (menesis)
importance: Undecided → Critical
milestone: none → 2.6.2
Tom Hoffman (tom-hoffman) wrote :

Ah, sorry I didn't see this earlier. I was looking for a question, not a bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers