Hide/unhide Deployed Worksheets

Bug #1261992 reported by Rafael PampaVilca on 2013-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SchoolTool Gradebook
Critical
Douglas Cerna

Bug Description

ACTION: Hide/unhide Deployed Worksheets
Button: SEND

Ha ocurrido un error del servidor interno. Esto probablemente significa que ha encontrado un fallo en SchoolTool. Por favor reportelo a la seccion de fallos..

Excepción
KeyError: u'course_computaci\xf3n_4-bimestre_1'

Traza
File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 132, in publish
  result = publication.callObject(request, obj)
File "/usr/lib/python2.7/dist-packages/zope/app/publication/zopepublication.py", line 207, in callObject
  return mapply(ob, request.getPositionalArguments(), request)
File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 107, in mapply
  return debug_call(obj, args)
Extra information: <schooltool.skin.flourish.zcml_content.FlourishHideUnhideCourseWorkheetsView_hide_unhide_worksheets.html object at 0xb2d0a78c>
File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 113, in debug_call
  return obj(*args)
File "/usr/lib/python2.7/dist-packages/schooltool/skin/flourish/page.py", line 77, in __call__
  self.update()
File "/usr/lib/python2.7/dist-packages/schooltool/gradebook/browser/course_worksheets.py", line 378, in update
  self.handleSheet(sheet, index, visible)
File "/usr/lib/python2.7/dist-packages/schooltool/gradebook/browser/course_worksheets.py", line 397, in handleSheet
  activities[deployedKey].hidden = sheet.hidden
File "/usr/lib/python2.7/dist-packages/schooltool/requirement/requirement.py", line 77, in __getitem__
  return self._data[key]

Douglas Cerna (replaceafill) wrote :

The reason for this bug is that before revision 636 [1], the gradebook didn't deploy course worksheets to new sections, and the Hide/Unhide view tries to get a key that was never deployed. Maybe we just need to double check that the deployedKey exists in the section activities.

affects: schooltool → schooltool.gradebook
Changed in schooltool.gradebook:
status: New → Confirmed
Douglas Cerna (replaceafill) wrote :

Oops, forgot the [1] reference in my previous comment:

[1] http://bazaar.launchpad.net/~schooltool-owners/schooltool.gradebook/trunk/revision/636

Changed in schooltool.gradebook:
status: Confirmed → Triaged
importance: Undecided → Critical
Changed in schooltool.gradebook:
status: Triaged → Fix Committed
assignee: nobody → Douglas Cerna (replaceafill)
Changed in schooltool.gradebook:
milestone: none → 2.6.4
Changed in schooltool.gradebook:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers