User not connected to correct section

Bug #1155226 reported by Rena Willis on 2013-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SchoolTool Gradebook
Critical
Douglas Cerna
SchoolTool Journal
Critical
Douglas Cerna

Bug Description

I have a user (teacher) that was previously working fine in both the journal and the gradebook. However, now when she logs into the system, her account is connected to the correct section on her calendar, but a different section in both the journal and gradebook. I have double checked the sections and she is listed correctly in her section and is not listed in the section that appears. I have deleted her from the section and re-added her, but to no avail. I added a new user and attached it to her section and this user works correctly.

I don't know anything about the database schooltool uses, but this feels like an indexing problem. Any suggestions you have would be appreciated.

Thanks,
Rena Willis
Lakeside International School

Changed in schooltool:
status: New → Triaged
status: Triaged → New
status: New → Triaged
importance: Undecided → High
assignee: nobody → Justas Sadzevičius (justas-pov)
Rena Willis (rwillis) wrote :

This has now happened on four other teachers. I can not seem to reproduce the steps that lead up to the problem. The teacher that I just encountered was the following:

1) I entered school tool as a user that is assigned to various sections. I worked as this user for a time in both the gradebook and the journal.

2) I logged out of the user and immediately logged in as another user who also is assigned to several sections. When I logged in as this user, the calendar was correct, but both the journal and the gradebook were "Stuck" on a section that does not belong to this user. As it happens this is the section I was last working on as the previous user. I did not have the option to view any other sections.

3) I closed the browser and flushed the cache and still no luck. I am attaching a screen grab of what comes up in the messed up user...

In the previous instances this did not happen on the same machine or in a situation where the same user was switching logins. I will continue to try and reproduce the problem. In the meantime the only solution appears to be adding a new user.

Changed in schooltool:
importance: High → Critical
assignee: Justas Sadzevičius (justas-pov) → Douglas Cerna (replaceafill)
Tom Hoffman (tom-hoffman) wrote :

Thanks Rena. We'll have at least one developer start on this Monday.

Changed in schooltool:
status: Triaged → In Progress
Douglas Cerna (replaceafill) wrote :

Rena:

We think this is caused by the teacher having administrative privileges in your instance combined with a bug on our code to "remember" the last section he visited. If the teacher visits a section where he is not an instructor, the Gradebook and Journal tabs will remember that section instead of *his* sections.

Could you try this workaround and let us know if it fixes your problem?

1. Log in as the teacher with the problem
2. Go to his Home tab
3. Display the Sections accordion and select a section he teaches
4. In the section view, click the Gradebook or Journal link in the sidebar
5. This will redirect you to that section's Gradebook or Journal and will make the application to remember the section (so the tabs will work again)

Tom Hoffman (tom-hoffman) wrote :

We will also fix the bug asap, but hopefully that workaround will let your teachers finish their work now!

Changed in schooltool:
status: In Progress → Fix Committed
Rena Willis (rwillis) wrote :

Sorry for the delay in answering... we have been on term break. I will try your workaround today! Thank you so much for your help and I'll let you know if I have any additional problems.

Thanks Again!

affects: schooltool → schooltool.gradebook
Changed in schooltool.lyceum.journal:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Douglas Cerna (replaceafill)
milestone: none → 2.4b1
Changed in schooltool.gradebook:
milestone: none → 2.4b1
Changed in schooltool.gradebook:
status: Fix Committed → Fix Released
Changed in schooltool.lyceum.journal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers