srfi/tests/multi-dimensional-arrays.sps expands to empty (begin) expressions

Bug #457739 reported by Derick Eddington on 2009-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Scheme Libraries
Low
Derick Eddington

Bug Description

Discovered by leppie when Ikarus was changed in revision 1864.

$ ikarus --r6rs-script srfi/tests/multi-dimensional-arrays.sps
Unhandled exception:
 Condition components:
   1. &who: begin
   2. &message: "invalid syntax"
   3. &syntax:
       form: (begin)
       subform: #f
   4. &source-position:
       file-name: "srfi/tests/multi-dimensional-arrays.sps"
       character: 676
   5. &trace: #<syntax (begin) [char 676 of srfi/tests/multi-dimensional-arrays.sps]>
   6. &trace: #<syntax (past)>
$

The problem is the (past) expressions in the definition of tail and the let-syntax binding of past.

Changed in scheme-libraries:
assignee: nobody → Derick Eddington (derick-eddington)
importance: Undecided → Low
status: New → In Progress

Fixed in revision 90.

Changed in scheme-libraries:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers