Linux x64 binary for 1.0.55 uses GLIBC 2.14

Bug #915171 reported by Miron Brezuleanu on 2012-01-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
SBCL
Undecided
Unassigned

Bug Description

... and many popular distributions still use GLIBC 2.13.

This makes the binary useful for a rather small fraction of the Linux x64 population (I'm using Linux Mint 12 fully upgraded, which is based on Ubuntu - since these two are rather popular and use recent software, I assume many other people don't have 2.14 yet).

I had no trouble compiling from sources on GLIBC 2.13, so it looks to me that there is no technical requirement to use GLIBC 2.14 - is there one? I'm worried that people that don't find it fun to compile from sources might jump to the conclusion that 'SBCL is hard to use/install etc.'.

This particular instance of the issue will probably go away by itself given a few weeks/months, but maybe it would be good to avoid using a bleeding edge system to compile binaries.

NOTE: my belief that I'm using 2.13 is based on the output of 'ldd --version'.

zmyrgel (timo-myyra) wrote :

Same issue with latest Slackware64 release (13.37). Unable to use binary as slack uses glibc 2.13. I'd rather see the binary package use the older glibc so wider audience can use them. Packagers can use then either binary package or compile own binaries from source.

Paul Khuong (pvk) wrote :

Looks like an oversight on the part of the most recent uploader of linux/x86oid binaries.

Changed in sbcl:
status: New → Confirmed
Holger Durer (h-duerer) wrote :

Still an issue with 1.0.57 on my Ubuntu 10.04.

Paul Khuong (pvk) on 2013-05-22
Changed in sbcl:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers