Steel Bank Common Lisp

Excessive compile time

Reported by Waldek Hebisch on 2011-06-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Undecided
Unassigned

Bug Description

sbcl 1.0.48 shows large compile time regression compilng FriCAS: earlier versions needed few minutes
of compile time, with sbcl 1.0.48 compilations takes more than 3 hours. The machine is 2.4 GHz Core 2
Quatro running 64-bit Fedora 9 (upgraded to 2.6.32 Linux kernel). In attachement there is a standalone
file which take 0.6s to compile using sbcl-1.0.16 but 416s using sbcl-1.0.48. Actually during FriCAS build
compiling this file took more than 1 hour. I had to add a few macros so that the file compiles independently
of the rest of FriCAS. I do not know what causes the difference between FriCAS build and standalone
compilation, but already standalone version shows huge regression.

Waldek Hebisch (hebisch) wrote :
Paul Khuong (pvk) on 2011-06-03
Changed in sbcl:
status: New → Confirmed
Paul Khuong (pvk) wrote :

Introduced in 1.0.46.33: constraint: Don't substitute REFs when replacement LEAF is not visible.

I looked a bit at randomly-sampled backtraces, and the change looks like it substantially increases the pressure on consets. How does that change interact with inline/local functions? Is let conversion guaranteed to run before cprop?

Paul Khuong (pvk) wrote :

FIND-CONSTRAINT on LAMBDA-VARs with 10k+ constraints is lossy.

Changed in sbcl:
assignee: nobody → Paul Khuong (pvk)
Paul Khuong (pvk) on 2011-06-12
Changed in sbcl:
status: Confirmed → In Progress
Paul Khuong (pvk) wrote :

Fixed in 1.0.49.55-e7100f1.

Paul Khuong (pvk) wrote :

Compile time down to < 2 seconds on my machine.

Changed in sbcl:
status: In Progress → Fix Committed
Paul Khuong (pvk) on 2011-06-20
Changed in sbcl:
assignee: Paul Khuong (pvk) → nobody
Waldek Hebisch (hebisch) wrote :

Yes, with current trunk FriCAS compilation is back to normal time. Thanks.

Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments