Added sb-ext:*suppress-print-errors*

Bug #709292 reported by Attila Lendvai on 2011-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Medium
Unassigned

Bug Description

Added sb-ext:*suppress-print-errors* modelled after *break-on-signals*.

Extended the various print functions and cl:describe to honour its value
and try to recover after errors coming from inside these functions.

patch available at: http://dwim.hu/gitweb/gitweb.cgi

Attila Lendvai (attila-lendvai) wrote :
tags: added: printer review

On Fri, 28 Jan 2011 15:27:48 -0000, Attila Lendvai <email address hidden> wrote:
> Public bug reported:
>
> Added sb-ext:*suppress-print-errors* modelled after *break-on-signals*.
>
> Extended the various print functions and cl:describe to honour its value
> and try to recover after errors coming from inside these functions.
>
> patch available at: http://dwim.hu/gitweb/gitweb.cgi

Thank you very much for this. This definitely deserves wider adoption,
IMO. Perhaps even a CDR.

--
regards,
  Samium Gromoff
--
"Actually I made up the term 'object-oriented', and I can tell you I
did not have C++ in mind." - Alan Kay (OOPSLA 1997 Keynote)

It looks like a clean commit except for a typo - "describeing".

Attila Lendvai (attila-lendvai) wrote :

originally i wanted to write DESCRIBE'ing or somesuch and then i've stepped back from it the wrong way.

now i'd suggest "DESCRIBE'ing" though, so that readers get the information that the error happened inside DESCRIBE.

Changed in sbcl:
assignee: nobody → Nikodemus Siivola (nikodemus)
Changed in sbcl:
status: New → Confirmed
Changed in sbcl:
importance: Undecided → Medium
status: Confirmed → In Progress
Nikodemus Siivola (nikodemus) wrote :

Attila, I've merged a modified (simplified) version into my pending tree.

https://github.com/nikodemus/SBCL/commit/26833e304336b5b9b4f21d83873c0a86522cf9fc

Does this meet your needs? (Sorry about being so slow about this.)

Nikodemus Siivola (nikodemus) wrote :

commit 171fde84561e232b8af8c05b82dfe8a8f9e08340
Author: Attila Lendvai <email address hidden>
Date: Fri Jan 28 16:09:47 2011 +0100

    add SB-EXT:*SUPPRESS-PRINT-ERRORS* modelled after *BREAK-ON-SIGNALS*

      When non-NIL, OUTPUT-OBJECT (our main entry to the printer) binds a handler
      that handles conditions of the specified type by printing an error marker
      instead of signaling an error.

      WRITE also accepts :SUPPRESS-ERRORS, and WITH-STANDARD-IO-SYNTAX binds it to
      NIL.

      Calls SIGNAL before handling the condition so outer handlers get a chance to
      use restarts, etc.

Changed in sbcl:
assignee: Nikodemus Siivola (nikodemus) → nobody
status: In Progress → Fix Committed
tags: removed: review
Attila Lendvai (attila-lendvai) wrote :

Nikodemus, one of the things i'm missing from my patch compared to what got comitted, is a restart to skip a slot when describe'ing an instance (custom SVUC's can often error).

Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers