Steel Bank Common Lisp

--script should defer undefined-function warnings

Reported by Tobias C. Rittweiler on 2010-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Wishlist
Unassigned

Bug Description

Last I tested, when using --script one had to order function definitions
before their uses, otherwise one would get an undefined-function
style-warning.

summary: - --script should defer warnings
+ --script should defer undefined-function warnings
Changed in sbcl:
assignee: nobody → Nikodemus Siivola (nikodemus)
importance: Undecided → Wishlist
status: New → In Progress
Changed in sbcl:
assignee: Nikodemus Siivola (nikodemus) → nobody
status: In Progress → Fix Committed
Nikodemus Siivola (nikodemus) wrote :

In 1.0.45.30.

Nikodemus Siivola (nikodemus) wrote :

Reverted the fix due to a regression as of 1.0.45.35. Will commit a better one after freeze.

Changed in sbcl:
assignee: nobody → Nikodemus Siivola (nikodemus)
status: Fix Committed → In Progress
tags: added: pending
Nikodemus Siivola (nikodemus) wrote :

In 1.0.46.3.

Changed in sbcl:
assignee: Nikodemus Siivola (nikodemus) → nobody
status: In Progress → Fix Committed
tags: removed: pending
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers