Steel Bank Common Lisp

xref / who-calls lossage on structure slots

Reported by Tobias C. Rittweiler on 2010-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Medium
Unassigned

Bug Description

Slot accesses of structures are mostly compiled through the
source-transforms set up by SLOT-ACCESSOR-TRANSFORMS
in src/code/defstruct.lisp.

However, source-transforms seem to be expanded as early as
during IR1-conversion which happens before XREF data is
computed.

Test case:

(defstruct foo
  slot)

(defun bar (x)
  (foo-slot x))

(format t "~&(WHO-CALLS 'FOO-SLOT) => ~S~%"
        (sb-introspect:who-calls 'foo-slot))

Changed in sbcl:
importance: Undecided → Medium
status: New → Confirmed
Nikodemus Siivola (nikodemus) wrote :

In SBCL 1.0.36.34.

Changed in sbcl:
status: Confirmed → Fix Committed

Nikodemus Siivola <email address hidden> writes:

> In SBCL 1.0.36.34.

I'll look into it tomorrow, but the returned Xref data seems to be
pretty inaccurate -- only getting to the toplevel form with M-? in
Slime.

  -T.

--
Diese Nachricht wurde auf Viren und andere gefaerliche Inhalte untersucht
und ist - aktuelle Virenscanner vorausgesetzt - sauber.
Freebits E-Mail Virus Scanner

Tobias C. Rittweiler (tcr) wrote :

"Tobias C. Rittweiler" <email address hidden> writes:

> Nikodemus Siivola <email address hidden> writes:
>
>> In SBCL 1.0.36.34.
>
> I'll look into it tomorrow, but the returned Xref data seems to be
> pretty inaccurate -- only getting to the toplevel form with M-? in
> Slime.

Fixed in 1.0.36.35.

  -T.

--
Diese Nachricht wurde auf Viren und andere gefaerliche Inhalte untersucht
und ist - aktuelle Virenscanner vorausgesetzt - sauber.
Freebits E-Mail Virus Scanner

Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers