failed AVER: (EQ (IR2-LVAR-KIND 2FIRST) UNKNOWN)

Bug #533930 reported by Eric Marsden on 2010-03-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SBCL
High
Unassigned

Bug Description

* (LAMBDA ()
  (BLOCK A
    (MULTIPLE-VALUE-PROG1 42
      (CATCH 'CT
        (HANDLER-BIND NIL
          (RETURN-FROM A
            (CATCH 'CT 43)))))))

debugger invoked on a SB-INT:BUG in thread #<THREAD "initial thread" RUNNING {1002AB4011}>:
    failed AVER: (EQ (IR2-LVAR-KIND 2FIRST) UNKNOWN)

(SBCL 1.0.36.13 running on Linux/AMD64)

Changed in sbcl:
status: New → Confirmed
importance: Undecided → High
Nikodemus Siivola (nikodemus) wrote :

Better test case, the issue is the DX cons inside the HANDLER-BIND:

        (LAMBDA ()
           (BLOCK A
             (MULTIPLE-VALUE-PROG1 42
               (CATCH 'CT
                 (let ((x (cons t t)))
                   (declare (dynamic-extent x))
                   (RETURN-FROM A (CATCH 'CT (foo x))))))))

Stas Boukarev (stassats) on 2013-11-15
tags: added: stack-analysis
Changed in sbcl:
status: Confirmed → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers