Failed aver (NOT (MEMQ PUSH END-STACK))

Bug #518099 reported by Eric Marsden on 2010-02-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
High
Unassigned

Bug Description

* (lisp-implementation-version)
"1.0.35.6"
* (LAMBDA (A)
  (BLOCK B1
    (MULTIPLE-VALUE-PROG1 42
      (CATCH 'CT1
        (RETURN-FROM B1
          (CATCH 'CT2
            (MIN 1 a)))))))

debugger invoked on a SB-INT:BUG in thread #<THREAD "initial thread" RUNNING {AA07749}>:
    failed AVER: (NOT (MEMQ PUSH END-STACK))

On Linux/x86.

Nikodemus Siivola (nikodemus) wrote :

Huh, I could have sworn we had an example of this on Launchpad already.

The problem is AFAIK that stack analysis is confused by unreachable code left in the component: because control-analysis isn't sufficiently aggressive re. functions in the component that are never called, particularly cleanups.

Changed in sbcl:
status: New → Confirmed
importance: Undecided → High

This bug is the close friend of 'nonlinear LVARs (aka MISC.293)' https://bugs.launchpad.net/sbcl/+bug/309099

The reproduction code is very similar in both cases, as well as the cleanup issues involved during the stack analysis.

Stas Boukarev (stassats) on 2013-11-15
tags: added: stack-analysis
Changed in sbcl:
status: Confirmed → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers