unused variables not reported for top-level LET form

Bug #492200 reported by Tobias C. Rittweiler on 2009-12-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Low
Unassigned

Bug Description

(let ((x 12)) ; => NO note
  (print 'hello))

(defun f ()
  (let ((x 12)) ; => note
    (print 'hello)))

 status confirmed
 tag compiler

(under COMPILE-FILE)

Changed in sbcl:
status: New → Confirmed
Changed in sbcl:
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: compiler-ir1
Douglas Katzman (dougk) wrote :

Nikodemus tagged this with 'ir1' but the problem is actually that it does not go through IR1.
The form outside a defun is fopcompilable, and the fopcompiler unfortunately omits various warnings as it walks the source code.
Unless a unified approach is adopted wherein the fopcompiler operates from IR1 after "normal" processing has generated IR1 and emitted whatever warnings it would, there will either be code duplication between the main compiler and fopcompiler, or there will be missing warnings.

Stas Boukarev (stassats) on 2014-12-26
Changed in sbcl:
assignee: nobody → Stas Boukarev (stassats)
Stas Boukarev (stassats) on 2015-02-14
Changed in sbcl:
assignee: Stas Boukarev (stassats) → nobody
Stas Boukarev (stassats) wrote :

In be7d952d646225bfc407405d9a17b80199db2aef

Changed in sbcl:
status: Triaged → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers