Bug #411563 reported by James Wright on 2009-08-10
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

Compiling a macro that allocates an array with dynamic dimensions and an :initial-contents argument on SBCL 1.0.30 built from source causes the AVER failure in the bug title.
I also encounter this error in 1.0.29, but not in 1.0.28.

To reproduce:
% sh --version
(running SBCL from: .)
SBCL 1.0.30

% uname -a
Linux tiny 2.6.24-23-generic #1 SMP Wed Apr 1 21:47:28 UTC 2009 i686 GNU/Linux

% cat define-matrix-game.lisp
;;;; define-matrix-game.lisp
;;; Attempting to reproduce the following bug:
;;; for versions of SBCL later than 1.0.28.
(in-package :cl-user)

(defmacro define-matrix-game (actionset-profile &rest payoffs)
  `(list ,(make-array (map 'list 'length actionset-profile) :initial-contents payoffs)))

% sh --no-userinit --eval '(load "define-matrix-game.lisp")'
(running SBCL from: .)
This is SBCL 1.0.30, an implementation of ANSI Common Lisp.
More information about SBCL is available at <>.

SBCL is free software, provided as is, with absolutely no warranty.
It is mostly in the public domain; some portions are provided under
BSD-style licenses. See the CREDITS and COPYING files in the
distribution for more information.

debugger invoked on a SB-INT:BUG:
  This is probably a bug in SBCL itself. (Alternatively, SBCL might have been
  corrupted by bad user code, e.g. by an undefined Lisp operation like
  (FMAKUNBOUND 'COMPILE), or by stray pointers from alien code or from unsafe
  Lisp code; or there might be a bug in the OS or hardware that SBCL is running
  on.) If it seems to be a bug in SBCL itself, the maintainers would like to
  know about it. Bug reports are welcome on the SBCL mailing lists, which you
  can find at <>.

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
  0: [CONTINUE] Ignore runtime option --eval "(load \"define-matrix-game.lisp\")".
  1: [ABORT ] Skip rest of --eval and --load options.
  2: Skip to toplevel READ/EVAL/PRINT loop.
  3: [QUIT ] Quit SBCL (calling #'QUIT, killing the process).

(SB-INT:BUG "~@<failed AVER: ~2I~_~A~:>")[:EXTERNAL]
0] *features*


Changed in sbcl:
status: New → In Progress
importance: Undecided → Medium
Changed in sbcl:
status: In Progress → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers