vanilla contribs cannot be used as asdf dependencies

Bug #393309 reported by Nikodemus Siivola on 2009-06-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SBCL
Low
Unassigned

Bug Description

(asdf:defsystem foo
  :depends-on (:sb-introspect))

(asdf:oos 'asdf:load-op :foo)

gives

component :SB-INTROSPECT not found, required by
#<SYSTEM "foo" {131196A1}>

Ideally all contribs but ASDF itself could be used as dependencies.

Attila Lendvai (attila-lendvai) wrote :

a much simpler reproduction of the bug is this:

CL-USER> (asdf:load-system :sb-executable)
; Evaluation aborted.
CL-USER> (require :sb-executable)
NIL
CL-USER>

the problem is that *some* contribs have no .asd file. namely these are the offenders:

- sb-executable
- sb-queue
- sb-sprof

(sb-executable doesn't seem to be a tested, generally useful contrib, maybe it should be removed from HEAD?)

some thoughts on asdf integration:

asdf:*central-registry* has the following form:

(LET ((ASDF::HOME (POSIX-GETENV "SBCL_HOME")))
  (WHEN (AND ASDF::HOME (NOT (STRING= ASDF::HOME "")))
    (MERGE-PATHNAMES "site-systems/" (TRUENAME ASDF::HOME))))

but it's pretty useless (also broken), because *system-definition-search-functions* has an entry to look up sbcl contrib .asd's.

Faré (fahree) wrote :

Note that this is fixed in my patch for new-style contribs
https://bugs.launchpad.net/sbcl/+bug/1132254

Stas Boukarev (stassats) on 2013-10-18
Changed in sbcl:
status: Confirmed → Fix Committed
Stas Boukarev (stassats) on 2013-10-31
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers