optimization failure with anything using SB-IMPL::UCD-GENERAL-CATEGORY

Bug #392206 reported by Nikodemus Siivola on 2009-06-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Medium
Nikodemus Siivola

Bug Description

(defun test-alpha-char-p (ch)
  (declare (character ch))
  (declare (optimize (speed 3) (safety 1) (debug 0)))
  (alpha-char-p ch))

says

; in: DEFUN TEST-ALPHA-CHAR-P
; (ALPHA-CHAR-P EV-PATHNAMES::CH)
; --> BLOCK < IF
; ==>
; (< (SB-IMPL::UCD-GENERAL-CATEGORY CHAR) 5)
;
; note: unable to
; open-code FLOAT to RATIONAL comparison
; due to type uncertainty:
; The first argument is a REAL, not a FLOAT.
;
; note: forced to do GENERIC-< (cost 10)
; unable to do inline fixnum comparison (cost 3) because:
; The first argument is a T, not a FIXNUM.
; unable to do inline fixnum comparison (cost 4) because:
; The first argument is a T, not a FIXNUM.
; etc.

Changed in sbcl:
assignee: nobody → Nikodemus Siivola (nikodemus)
Changed in sbcl:
status: Confirmed → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers