Steel Bank Common Lisp

READ-CHAR-NO-HANG misbehaviour on Windows Console

Reported by Nikodemus Siivola on 2008-12-17
4
Affects Status Importance Assigned to Milestone
SBCL
Medium
David Lichteblau

Bug Description

BUGS #421

It seems that on Windows READ-CHAR-NO-HANG hangs if the user
has pressed a key, but not yet enter (ie. SYSREAD-MAY-BLOCK-P
seems to lie if the OS is buffering input for us on Console.)

reported by Elliot Slaughter on sbcl-devel 2008/1/10.

description: updated
Changed in sbcl:
status: New → Confirmed
Changed in sbcl:
importance: Undecided → Medium
Tobias C. Rittweiler (tcr) wrote :

This bug hinders SLIME from working correctly with SBCL on Windows.

See http://article.gmane.org/gmane.lisp.slime.devel/7991 for more details.

I hence propose to change the Importance of this bug to High.

Nikodemus Siivola (nikodemus) wrote :

Marked as HIGH, but this is for now best worked around in Slime.

(Intrepid Windows people: the place look at is src/code/win32.lisp, DEFUN HANDLE-LISTEN.)

Changed in sbcl:
importance: Medium → High

Knocking this down to Medium because SLIME has had a workaround for quite a while, and there has been no activity on this in more than a year.

Changed in sbcl:
importance: High → Medium
Changed in sbcl:
assignee: nobody → David Lichteblau (david-lichteblau)
Changed in sbcl:
status: Confirmed → Fix Committed
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers