1.4.0 does not pass tests with sb-fasteval enabled

Bug #1722097 reported by Faried Nawaz on 2017-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Undecided
Unassigned

Bug Description

Ubuntu 14.04, x86_64. uname -a:

Linux quad-damage 3.13.0-132-generic #181-Ubuntu SMP Wed Sep 13 13:25:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

git checkout sbcl-1.4.0
sh make.sh --fancy --with-sb-fastevel --with-sb-doc --without-sb-eval
cd tests && sh run-tests.sh
[...]
Status:
 Failure: compiler.pure.lisp / COMPILE-LOAD-TIME-VALUE-INTERPRETED-MODE
 Expected failure: compiler.pure.lisp / MV-CALL-TYPE-DERIVATION
 Expected failure: threads.pure.lisp / (WAIT-ON-SEMAPHORE SEMAPHORE-NOTIFICATION LP-1038034)
 Failure: compiler.impure.lisp / (EVAL BAD LAMBDA-LIST KEYWORD PROGRAM-ERROR)
 Failure: eval.impure.lisp / (BUG-573747 EVAL INTERPRET)
 Expected failure: packages.impure.lisp / USE-PACKAGE-CONFLICT-SET
 Expected failure: packages.impure.lisp / IMPORT-SINGLE-CONFLICT
 (11 tests skipped for this combination of platform and features)
test failed, expected 104 return code, got 1

It passes all tests if I build it with

sh make.sh --fancy --with-sb-doc

I am unable to test master; I think I'm currently between commits (failing with 5a4a818671235e5d91ad2188a3923540df7ca348).

Douglas Katzman (dougk) wrote :

I currently show all tests passing. Could you try this at latest head?

Faried Nawaz (faried) wrote :

I just tried building master (commit 4880395730c12040ee33bed4f3789b13ecb6f31d) on Ubuntu 12.04 and 16.04, and tests failed on both of them with the same error as in my bug report. On the 12.04 system I built sbcl using 1.3.20, and on 16.04 with 1.3.1.debian (ships with xenial). I can check on 14.04 when I get back home in a few hours.

Faried Nawaz (faried) wrote :

My 14.04 system reports the same test failure, against 173f9b92e5a7e846cba7e8cc68e1688996fd7d0c.

Stas Boukarev (stassats) wrote :

The OS version doesn't really matter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers