build fails with "no size function" on macOS in CI env

Bug #1678347 reported by alexdunn on 2017-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SBCL
Undecided
Unassigned

Bug Description

On Sierra, El Capitan, and Yosemite, I'm seeing the following failure when trying to build 1.3.16 using 1.2.11 as the bootstrap image (relatedly, could we get more recent Darwin binaries?):

```
==> ./make.sh --prefix=/usr/local/Cellar/sbcl/1.3.16 --with-after-xc-core --xc-host=/private/tmp/sbcl--bootstrap64-20170401-59298-1djvs6m/sbcl-1.2.11-x86-64-darwin/src/runtime/sbcl --core /private/tmp/sbcl--bootstrap64-20170401-59298-1djvs6m/sbcl-1.2.11-x86-64-darwin/output/sbcl.core --disable-debugger --no-userinit --no-sysinit --with-sb-core-compression --with-sb-ldb --with-sb-thread

[...snip...]

* ; Removing placeholder PRINT-OBJECT ... done
; Fixed ftypes: (%MAKE-ARRAY %MAP %TYPEP ADJUST-ARRAY CERROR CHECK-TYPE-ERROR CLASS-OF COERCE COERCE-TO-CONDITION CONCATENATE COPY-PPRINT-DISPATCH SB-PCL:ENSURE-CLASS-FINALIZED ERROR FIND-CLASS LIST-TO-VECTOR* MAKE-ARRAY MAKE-CONDITION MAKE-SEQUENCE MAKE-STRING MAKE-STRING-OUTPUT-STREAM MAP MERGE OPEN PPRINT-DISPATCH SET-PPRINT-DISPATCH SIGNAL STREAM-ELEMENT-TYPE SUBTYPEP TYPE-OF TYPEP UPGRADED-ARRAY-ELEMENT-TYPE UPGRADED-COMPLEX-PART-TYPE VECTOR-TO-VECTOR* WARN)
FUN-INFO: Collapsed 1362 -> 755
Disassembler: 90 printers, 39 prefilters, 4 labelers
NIL
* [undoing binding stack and other enclosing state... done]
[defragmenting immobile space... 645+15254+28624+17839 objects... done]
[saving current Lisp image into output/sbcl.core:
fatal error encountered in SBCL pid 3264(tid 0x7fffcc1f73c0):
no size function for object at 0x21c7e0a0 (widetag 0x31)
```

Full logs for all three OS versions: https://gist.github.com/dunn/cf96b66e0937165ccde795bf47745df6

This is occurring on the Homebrew CI servers (PR: https://github.com/Homebrew/homebrew-core/pull/11904), and I haven't been able to replicate it locally. But I haven't been able to find many clues as to what the cause might be, so I'm hoping someone might be able to point me in the right direction.

Thanks!

Stas Boukarev (stassats) wrote :

In 075f1de45cd2b142c739ef5d56bbb1cc7ffe9a07.

Changed in sbcl:
status: New → Fix Committed
alexdunn (dunn-alex) wrote :

That did it, thanks so much!

Stas Boukarev (stassats) on 2017-04-28
Changed in sbcl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers