failed to build sb-thread on mac os x mavericks

Bug #1272398 reported by yann ics on 2014-01-24
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

Impossible to build sbcl with sb-thread on mac os x mavericks:
I have tried:
- port install sbcl +threads
- sh --with-sb-thread
in the end, I got the following message:
WARNING! Some of the contrib modules did not build successfully or pass their self-test. Failed contribs: sb-posix

sbcl --version
SBCL 1.1.14

uname -a
Darwin mbp-de-yann.home 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64


Stas Boukarev (stassats) wrote :

It seems that you forgot to attach the build log.

Changed in sbcl:
status: New → Incomplete
yann ics (by-cmsc) wrote :
Stas Boukarev (stassats) wrote :

You have a file in the root directory which includes characters in its name which cannot be decoded with the encoding SBCL is configured to use. To change the encoding SBCL defaults to, environment variables LC_CTYPE or LANG can be set to a desired locale, e.g. en_US.UTF-8.

Changed in sbcl:
status: Incomplete → Invalid
yann ics (by-cmsc) wrote :

I did set LANG and LC_ALL to en_US.UTF-8.
The only change is:
Error: Processing of port sbcl failed

yann ics (by-cmsc) on 2014-01-25
Changed in sbcl:
assignee: nobody → yann ics (by-cmsc)
assignee: yann ics (by-cmsc) → nobody
yann ics (by-cmsc) wrote :

Is there a way to get help here or somewhere else.
About my problem, I tried everything like;
in .bashrc and .profile ---> export LANG=C (I tried en_US.UTF-8, POSIX, ...); export LC_ALL=C (I tried en_US.UTF-8, POSIX, ...).
I did build sb-thread from source (can't get the binary) with:
sh --with-sb-thread
and also with customize-target-features.lisp:
(lambda (features)
      (flet ((enable (x)
               (pushnew x features))
             (disable (x)
               (setf features (remove x features))))
        ;; Threading support.
        (enable :sb-thread)))
and run:
sh && sudo sh

I have tried with macport:
sudo port install sbcl +threads

and in the end the same problem
sb-posix test failed.

Thanks for any help.

yann ics (by-cmsc) on 2014-02-09
Changed in sbcl:
status: Invalid → Opinion
Stas Boukarev (stassats) wrote :

sb-posix test fails because of the encoding.

Changed in sbcl:
status: Opinion → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers