sbackup crashes at backup -->Zombie

Bug #455377 reported by LAZA on 2009-10-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sbackup
Status tracked in Trunk
0.10
Low
Unassigned
0.11
Wishlist
Unassigned
Trunk
Wishlist
Unassigned

Bug Description

Every time I start myself 'sbackup' the program (with Backup Now!) works and starts itself the neccessary packer etc.
But 'sbackup' itself reacts to nothing!
Looking in the taskmanager the process ist listed as 'Zombie'.
The automatic backups work without problems...

LAZA (laza74) wrote :

Ubuntu 9.04
Linux ubuntu 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:48:52 UTC 2009 x86_64 GNU/Linux

LAZA (laza74) wrote :

still in Lucid!

LAZA (laza74) wrote :

If I try to kill the process it is still in the task manager and is waiting with 'do_exit'...

but is not 'exiting' at all so I had to kill the process on the command line!

DiQ (dik23) wrote :

I also get this

However I do not need to kill via cli, if I close the SBackup gui the zombie python process dies.

However, it makes no backup

DiQ (dik23) wrote :

I have moved one of my machines back to nssbackup and now I am getting this error in that program too !

Jean-Peer Lorenz (peer.loz) wrote :

If you hit this issue with nssbackup please open a new bug at https://bugs.launchpad.net/nssbackup

Please, don't forget to include the following:

* version and installed from where
* your OS
* a brief description of your setup and backup configuration
* run as superuser/regular user?
* your configuration file in question
* log files with debug output enabled
* list steps to reproduce the issue
* output when started from command line

The same information are required to track down the problem in SBackup!

Thanks a lot.

Changed in sbackup:
status: New → Incomplete
DiQ (dik23) wrote :

Ok - sorry

I am using sbackup 0.11.1 from the nss ppa on Lucid 32 backing up to a partition /backup as sudo.

Backup seems to work fine but as soon as I click "Make a backup now" on the gui I get a zombie under

python /usr/sbin/sbackup-config-gtk

running as root

This goes away when the gui is closed so not sure how important it is

LAZA (laza74) wrote :

WHAT IS MISSING???

Cause of dik23 writes about his problems with nssbackup (or another program) this bug in SBACKUP is not gone!

Jean-Peer Lorenz (peer.loz) wrote :

@LAZA:

In order to track down the cause of the problem some more information are required. Please answer the following questions:

* do you see this bug with latest sbackup 0.11.x installed from PPA?
* what distribution do you use?
* what version of sbackup is installed; from where was it installed (PPA, from source)?
* Is the bug reproducible; does it happen every time?
* do you run sbackup as superuser (root) or as regular user?

Thanks for your help.

LAZA (laza74) wrote :

*do you see this bug with latest sbackup 0.11.x installed from PPA?

I tried it now - seems to work!
Installed is now: 0.11.3ppa1~lucid1

* what distribution do you use?

Ubuntu (at this time surely 9.10) - now 10.04.1

* what version of sbackup is installed; from where was it installed (PPA, from source)?

I used the original packages from Ubuntu (0.10.x)

* Is the bug reproducible; does it happen every time?

Yes, tried it 3-5 times!

* do you run sbackup as superuser (root) or as regular user?

root

LAZA (laza74) wrote :

Correction:

The process
/usr/bin/sbacku (there is an 'p' missing)
is now a Zombie!

Backup still works but veeeery slowly (55 % in 7.3 hours!) and the process must have been crashes meanwhile...
Normally the backup finishes in max six hours while Transmission and BOINC work in the background!
As before in the older versions: Planned backups work without problems accurate.

For more infos don't hesitate to ask.

Ubuntu 10.04.1
Linux Ubuntu 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64 GNU/Linux
sbackup 0.11.3ppa1~lucid1

Jean-Peer Lorenz (peer.loz) wrote :

I can reproduce this issue with following steps:

1. start sbackup-config-gtk
2. click 'Make backup now' button and start a backup process
3. keep sbackup-config-gui open until backup process has finished

-> the backup process (Python) remains in Zombie state until sbackup-config-gui (its parent) is closed.

(Tried with sbackup 0.11.3 from Universe on Ubuntu Maverick 10.10).

Jean-Peer Lorenz (peer.loz) wrote :

Setting this to low priority Wishlist because it actually does not affect users: the zombie process exits when sbackup-config-gtk is closed.

LAZA (laza74) wrote :

Worked for me under Ubuntu 10.10 with sbackup 0.11.3ubuntu1.

I had to do a fresh backup manuelly and it worked without problems over night.

Thanks for the support!

Jean-Peer Lorenz (peer.loz) wrote :

Reminder to keep track of this: To make sure no zombie will stay around, it is necessary to detach the backup process from its parent process (i.e. sbackup-config-gtk).

This is properly implemented in trunk (but not yet released).

Since this is minor issue, it won't get fixed in sbackup 0.11 series.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers