Cannot perform an incremental backup

Bug #694788 reported by Jeremy on 2010-12-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sbackup
Undecided
Unassigned

Bug Description

I am told Simple Backup is supposed to make incremental backups but every backup it seems to make is the full size of my installed files and all end in .ful. I selected "Take full backup" only the first time and all other times have specifically left that box unchecked. If I can't make it take smaller incremental snapshots I'm going to run out of room. What can I do?!

Jean-Peer Lorenz (peer.loz) wrote :

Thank you for using SBackup and for taking the time reporting this bug.

In order to track down the cause of the problem some more information are required. Please answer the following questions:

* what distribution do you use?
* what version of sbackup is installed; from where was it installed (PPA, from source)?
* Is the bug reproducible; does it happen every time?
* is your backup destination on a local drive or remote?
* do you run sbackup as superuser (root) or as regular user?
* Do backups work in general for you?
* Do manual backups (started from Configuration GUI) work as expected?
* How do you invoke the backup process?

Thanks for your help.

Changed in sbackup:
status: New → Incomplete
Jeremy (jeremyfrankly) wrote :

1. I am using version 0.11.3ubuntu1 on Maverick from the Ubuntu repository.
2. The bug happens every time
3. I am backing up to a folder on an external ext4 drive
4. I run as root so I can back up /var and /opt and other folders like that. I also have a "Home" profile that only does my home folder
5. The backups seem to work in general. Using the two profiles I get backups of 1.5GB and 60GB which should be accurate
6. I only run manual backups, never scheduled
7. I use "gksu --description /usr/share/applications/sbackup-config-su.desktop /usr/bin/sbackup-config-gtk" to launch SBackup and select "Backup Now" from the menu to make backups

Jeremy (jeremyfrankly) wrote :

Ok, I may have discovered something. I had it set for "Make a full backup every [0] days" trying to never make it automatically make another full backup. This may have had the opposite effect. I changed the system profile (system files and NOT /home) it to fifty days and tried again and while it did make a .inc it went from a 1.5GB file to 1.6GB so unless every folder on my system upgraded within a week I don't think it made a real incremental backup. I'm about to try again with the home profile set to 50 as well.

Jeremy (jeremyfrankly) wrote :

I'm not sure this problem is *quite* solved yet. Now both profiles are successfully making .inc backups but they remain the same size as their .ful counterparts (and take the same amount of time to back up) so I don't think they're really incremental backups.

Jean-Peer Lorenz (peer.loz) wrote :

Any news? Could you please set up a small test case (1 directory, some files) and perform full and incremental backups and post your outcomes? Thanks for your help.

Jeremy (jeremyfrankly) wrote :

Don't know why, but it seems to be working now

Jean-Peer Lorenz (peer.loz) wrote :

I'm glad to hear it is working for you. Thanks again for using sbackup and please post any issues or feature requests.
Best regards. Jean-Peer

Changed in sbackup:
status: Incomplete → Invalid
Howard Cheng (howard-cheng) wrote :

I think this may be the same problem that I am having. But my problem is not solved yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions