Error when destination path is changed

Bug #1174124 reported by Wolfgang Jansen on 2013-04-29
312
This bug affects 65 people
Affects Status Importance Assigned to Milestone
sbackup
Low
Unassigned
0.11
Low
Unassigned

Bug Description

Hello,

when trying to start sbackup the following error message is issued:

coercing to Unicode: need string or buffer, NoneType found

Traceback (most recent call last):
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1103, in on_dest1_toggled
    self.on_dest_localpath_selection_changed()
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1542, in on_dest_localpath_selection_changed
    if (os.path.isdir(_target) and os.access(_target, os.R_OK | os.W_OK | os.X_OK)):
  File "/usr/lib/python2.7/genericpath.py", line 41, in isdir
    st = os.stat(s)
TypeError: coercing to Unicode: need string or buffer, NoneType found

The message also asks me to send the bug report: done here,
and to try sbackup again. Then the program starts and runs as expected.

With regrads
WJ

PS: platform info
- Linux ubuntu 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
- sbackup 0.11.4

This is the new Ubuntu 13.04. Well, it is rather new, nevertheless,
sbackup already worked with the new version.
I installed sbackup from the ppa some months ago.
I do not know whether the new ubuntu installation
did upgrade sbackup (I did not).

Giacomo (poderi1980) wrote :

I have the same problem. I receive the following message in the error window:

"coercing to Unicode: need string or buffer, NoneType found

Traceback (most recent call last):
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1103, in on_dest1_toggled
    self.on_dest_localpath_selection_changed()
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1542, in on_dest_localpath_selection_changed
    if (os.path.isdir(_target) and os.access(_target, os.R_OK | os.W_OK | os.X_OK)):
  File "/usr/lib/python2.7/genericpath.py", line 41, in isdir
    st = os.stat(s)
TypeError: coercing to Unicode: need string or buffer, NoneType found"

I run on: Linux vulcan 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
I upgraded from 12.10 and never used sbackup after the upgrade.

Jean-Peer Lorenz (peer.loz) wrote :

Thank you for reporting this issue. I'll look into it. At first sight it looks like some new resp. changed behaviour due to the Python version shipped with Ubuntu 13.04.

Changed in sbackup:
importance: Undecided → Low
Changed in sbackup:
status: New → Triaged
Wolfgang Jansen (wo-jansen) wrote :

Sorry, the bug fix does not work either:
The error window is shown again when I want to choose a non-standard destination.
After dismissing the error window I am able to enter the destination
(entry "Use custom local backup directory") but the setting is ignored
and the backup is stored to the standard destination (what I wanted to avoid).

WJ

Changed in sbackup:
status: Triaged → Confirmed
summary: - sbackup fails to start
+ Error when destination path is changed
Omk (ossi-viljakainen) wrote :

Just installed sbackup on my new laptop, and got this same error.

Traceback (most recent call last):
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1103, in on_dest1_toggled
    self.on_dest_localpath_selection_changed()
  File "/usr/share/sbackup/sbackup/ui/configgui.py", line 1542, in on_dest_localpath_selection_changed
    if (os.path.isdir(_target) and os.access(_target, os.R_OK | os.W_OK | os.X_OK)):
  File "/usr/lib/python2.7/genericpath.py", line 41, in isdir
    st = os.stat(s)
TypeError: coercing to Unicode: need string or buffer, NoneType found

ragnaroknroll (ragnaroknroll) wrote :

Same error here using Linux Mint 15

Changed in sbackup:
status: Confirmed → Fix Released

Nice

… but I don't know how to install this 11.6 on my Mint15 (Ubuntu 13.04)

Jean-Peer Lorenz (peer.loz) wrote :

Hi Robert,
you should be able to install from our PPA. You can find it here: https://launchpad.net/~sbackup-team/+archive/stable

Best regards.

thanks, updated.
The old nss PPA stood in my PPA list

JLuc (jluc-q) wrote :

I'm using Simple Backup Suite 0.11.4 on ubuntu 13.10 and i have same issue when wanting to choose the save destination folder

just install the PPA to be found in https://launchpad.net/~sbackup-team/+archive/stable (see #7)

Thank you very much, SBackup just works fine now !

Best regards,

Marc

Le 08. 02. 14 10:27, robert leleu a écrit :
> just install the PPA to be found in https://launchpad.net/~sbackup-
> team/+archive/stable (see #7)
>

Jose Trindade (jcftrindade) wrote :

Works fine now. Thanks

Jean-Peer Lorenz (peer.loz) wrote :

Summary note:

this affects sbackup 0.11.4 and 0.11.5. Latest is sbackup 0.11.6 (unaffected).

On Ubuntu 13.10 please install latest version from PPA.
On Ubuntu 14.04 just install from repositories (latest is included).

Franz Hartwig (franz-hartwig) wrote :

Thank you. Just installed 0.11.6, seems to work. I did not have installed the ppa. I don't know why. Now I caught it up ...

Franz

Sylvain Félix (sylv1-felix) wrote :

Ok, thank you for your reponse

Sylvain
Le 12. 04. 14 16:03, Jean-Peer Lorenz a écrit :
> Summary note:
>
> this affects sbackup 0.11.4 and 0.11.5. Latest is sbackup 0.11.6
> (unaffected).
>
> On Ubuntu 13.10 please install latest version from PPA.
> On Ubuntu 14.04 just install from repositories (latest is included).
>

To post a comment you must log in.