posh ohai should check powershell version and fail gracefully

Bug #1390208 reported by Sam Stavinoha on 2014-11-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
satori
High
Sam Stavinoha

Bug Description

Using the PoSh-Ohai system info provider on a Windows system lacking an adequate powershell version will end badly. The powershell version should be detected initially and a proper custom exception should be raised to precisely indicate the cause of failure.

The PoSh-Ohai deploy script now contains a powershell version check, which will make the change fairly trivial in posh_ohai.py

https://github.com/rackerlabs/PoSh-Ohai/commit/ddc79a525b3d4f79df7e9c4542330b8c34cfdcad

Fix proposed to branch: master
Review: https://review.openstack.org/133118

Changed in satori:
status: Confirmed → In Progress

Change abandoned by Monty Taylor (<email address hidden>) on branch: master
Review: https://review.openstack.org/133118
Reason: This change has been abandoned because it belongs to a project that is part of the StackForge retirement. See http://governance.openstack.org/resolutions/20150615-stackforge-retirement.html for more details.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers