error invoking flake8

Bug #1347093 reported by Sam Stavinoha on 2014-07-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
satori
High
Sam Stavinoha

Bug Description

When trying to invoke `flake8`
-----------------------------------------------------------------------------
Traceback (most recent call last):
  File "~/.virtualenvs/satori-dependencies-dev/bin/flake8", line 11, in <module>
    sys.exit(main())
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/flake8/main.py", line 24, in main
    flake8_style = get_style_guide(parse_argv=True, config_file=DEFAULT_CONFIG)
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/flake8/engine.py", line 89, in get_style_guide
    kwargs['parser'], options_hooks = get_parser()
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/flake8/engine.py", line 40, in get_parser
    (extensions, parser_hooks, options_hooks) = _register_extensions()
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/flake8/engine.py", line 26, in _register_extensions
    checker = entry.load()
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/pkg_resources.py", line 2028, in load
    if require: self.require(env, installer)
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/pkg_resources.py", line 2041, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer)))
  File "~/.virtualenvs/satori-dependencies-dev/local/lib/python2.7/site-packages/pkg_resources.py", line 576, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pep8 1.4.7a0 (~/.virtualenvs/satori-dependencies-dev/src/pep8), Requirement.parse('pep8>=1.5.7'))
-----------------------------------------------------------------------------

Sam Stavinoha (smlstvnh) on 2014-07-22
description: updated
Changed in satori:
importance: Undecided → Critical
importance: Critical → High

Reviewed: https://review.openstack.org/108813
Committed: https://git.openstack.org/cgit/stackforge/satori/commit/?id=e7aee8a7cdea78318476b332692b59ea06812dd8
Submitter: Jenkins
Branch: master

commit e7aee8a7cdea78318476b332692b59ea06812dd8
Author: Samuel Stavinoha <email address hidden>
Date: Tue Jul 22 18:51:37 2014 +0000

    fix tests and test requirements

    Changes to python-whois require updates to dns unittests.

    Updates pep8 requirement from jcrocholl/pep8 Issue#240:
        Fix was merged into pep8 1.5.7
    Updates hacking requirement to fix VersionConflict

    Change-Id: I44deeb5f7b164f6a40d4eabc68630f373ea2167a
    Implements: blueprint dependency-fix
    Closes-Bug: #1347093

Changed in satori:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers