Ubuntu 11.10 ignores settings of samsung-tools.

Reported by Dmitriy on 2011-11-01
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Samsung Tools
Undecided
Unassigned

Bug Description

I selected to disable bluetooth, web-cam, wi-fi and to choose silent mode of CPU on start. But after restarting system all of these devices are enabled, end CPU mode is normal.
Settings in /etc/samsung-tools/system.conf are correct.
What can cause the problem?

Suhaimi Ghazali (suhaimighz88) wrote :

I also selected disable bluetooth and webcam. But each login, they still enabled. Also can't remember brightness settings too.
The screen always on the lowest settings when on battery.
Samsung N148 plus here.

Benrizz (benrizz) wrote :

I've got the same problem on my samsung NC-110.

Samsung tools can not remember settings even if I configure it through Samsung-tools-preferences.

Fortunato Ventre (voria) wrote :

I can't reproduce this bug on my installation.
Anyway, the only culprit for this bug I can think of is the upstart service (its work is to set intial status for devices), which is probably not started automatically at boot, for some reason.

Please try the following:

- Set a device (for instance, wireless) to be disabled at boot.
- Enable it with the hotkey or the command line utility.
- Start the upstart service with this command:
  sudo service samsung-tools start

If at this point the device is disabled, then the upstart service works as intended and the problem lies in the fact it's not automatically started at boot.

@Suhaimi Ghazali (suhaimighz88):
'samsung-tools' does not handle the screen brightness level, it just handles the screen backlight (on or off).

Fortunato Ventre (voria) wrote :

Please test the new samsung-tools (2.0~ppa1~loms~oneiric~test6) available on my testing repository and let me know if it fixes the problem for you:

https://launchpad.net/~voria/+archive/archive/+packages

Benrizz (benrizz) wrote :

It is indeed the upstart service that doesn't start automatically (i tried what you asked).

Unfortunately, the new samsung tools 2.0 does not fix the problem.

Thanks for your efforts

Fortunato Ventre (voria) wrote :

I think I've found the source of the problem.

Since I'm a kubuntu user, I didn't notice the new ubuntu uses lightdm as the default display manager in place of the old gdm.
The upstart service of samsung-tools is started only when the display manager is already running, but it only checks for gdm and kdm.

I've added support for lightdm as well, so the bug should be fixed now.
Please test the new samsung-tools (2.0~ppa1~loms~oneiric~test7) available on my testing repository and let me know if it's working:

https://launchpad.net/~voria/+archive/archive/+packages

Fortunato Ventre (voria) on 2011-11-27
Changed in samsung-tools:
milestone: none → 2.0

It's working for me! Thanks a lot for fixing the problem!

2011/11/27 Fortunato Ventre <email address hidden>:
> I think I've found the source of the problem.
>
> Since I'm a kubuntu user, I didn't notice the new ubuntu uses lightdm as the default display manager in place of the old gdm.
> The upstart service of samsung-tools is started only when the display manager is already running, but it only checks for gdm and kdm.
>
> I've added support for lightdm as well, so the bug should be fixed now.
> Please test the new samsung-tools (2.0~ppa1~loms~oneiric~test7) available on my testing repository and let me know if it's working:
>
> https://launchpad.net/~voria/+archive/archive/+packages
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/884686
>
> Title:
>  Ubuntu 11.10 ignores settings of samsung-tools.
>
> Status in Samsung Tools:
>  New
>
> Bug description:
>  I selected to disable bluetooth, web-cam, wi-fi and to choose silent mode of CPU on start. But after restarting system all of these devices are enabled, end CPU mode is normal.
>  Settings in /etc/samsung-tools/system.conf are correct.
>  What can cause the problem?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/samsung-tools/+bug/884686/+subscriptions
>

Fortunato Ventre (voria) wrote :

Good. :)
I'll close this bug then.

Changed in samsung-tools:
status: New → Incomplete
status: Incomplete → Fix Committed
SHAYEK (7shayek) on 2011-11-28
description: updated
Fortunato Ventre (voria) on 2011-11-28
Changed in samsung-tools:
status: Fix Committed → Fix Released
SHAYEK (7shayek) wrote :

when i restart my samsung NP NC108 netbook, then all settings changed. Bluetooth became on and screen brightness became less than what i set it before restart. give me solution :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers